Bug 142612 - Compiling Boost 1.32.0 Failed in RHEL 3.0 on Itanium2
Compiling Boost 1.32.0 Failed in RHEL 3.0 on Itanium2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: boost (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Benjamin Kosnik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-10 16:41 EST by Granville Xiong
Modified: 2013-08-09 01:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.fc3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-25 18:23:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Granville Xiong 2004-12-10 16:41:54 EST
Description of problem:

First of all, Boost 1.32.0 can be compiled correctly
in RHEL 3.0 (Update 3) on IA32 platform without any problems.

But when I tried to compile it on a quad-Itanium2
system, I ran into the following problem:

I issued the standard building command:

rpmbuild --rebuild boost-1.32.0-3.src.rpm

which supposes to compile the released version of both the static and 
the dynamic, as specified by the building command in the SPEC file in 
the souce RPM:
 
bjam "-sTOOLS=gcc" "-sBUILD=release" stage

I always ended up with the following error messages during the 
compilation:

gcc-C++-action
bin/boost/libs/thread/build/libboost_thread.so/gcc/debug/shared-l
inkable-true/threading-multi/barrier.o
In file included from
/home/xyg/downloads/boost_1_32_0/boost/thread/detail/config.hpp:18,
                 from
/home/xyg/downloads/boost_1_32_0/libs/thread/src/barrier.cpp:12:
/home/xyg/downloads/boost_1_32_0/boost/config/requires_threads.hpp:47:
5:
#error "Compiler threading support is not turned on. Please set the 
correct command line options for threading: -pthread (Linux), -
pthreads (Solaris) or -mthreads (Mingw32)"

Since my Itanium2 runs RHEL 3.0 with the standard GCC 3.2.3, the same 
version of the GCC that I used to compile Boost in RHEL 3.0 on IA32 
platform, I don't understand why this error happened.

One more thing I found out is that:

It seems that all the troubles are caused by the undefined 
BOOST_HAS_THREADS, which then causes the breaking down in:

boost_root/boost/config/requires_threads.hpp

I don't understand why this didn't cause a problem in RHEL GCC 3.2.3 
on IA32.

Version-Release number of selected component (if applicable):

boost-1.32.0-3.src.rpm

How reproducible:

Everytime!

Steps to Reproduce:
1. Download boost-1.32.0-3.src.rpm from Redhat Fedora site
2. rpmbuild --rebuild boost-1.32.0-3.src.rpm
3. Compilation fails!
  
Actual results:

Compilation fails!

Expected results:

Boost should be compiled on IA64 without any problems as it does on 
IA32.

Additional info:
Comment 1 Benjamin Kosnik 2005-03-17 00:48:30 EST
I added this patch back into the mix with boost-1.32.0-4, which is now in
updates-testing. It should be pushed out shortly for FC-3 and RHEL-4.

-benjamin

Note You need to log in before you can comment on or make changes to this bug.