Bug 1426194 - unable to deploy compute node with sriov agent only (no ovs agent)
Summary: unable to deploy compute node with sriov agent only (no ovs agent)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 12.0 (Pike)
Assignee: RHOS Maint
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks: 1402132 1414427 1528947
TreeView+ depends on / blocked
 
Reported: 2017-02-23 12:09 UTC by Alon Dotan
Modified: 2018-10-18 07:24 UTC (History)
19 users (show)

Fixed In Version: puppet-tripleo-7.1.1-0.20170719150224.cb66aeb.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-12-13 21:11:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1679202 None None None 2017-04-03 15:11:17 UTC
OpenStack gerrit 452786 None None None 2017-04-03 15:12:29 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Alon Dotan 2017-02-23 12:09:19 UTC
Description of problem:
unable to deploy compute node with sriov agent only (no ovs agent)

Version-Release number of selected component (if applicable):


How reproducible:
deploy overcloud with OS::TripleO::Services::ComputeNeutronOvsAgent: OS::Heat::None (like with opendaylight for example)

Steps to Reproduce:
1.
2.
3.

Actual results:
the sriov agent will failed to load

Expected results:


Additional info:
this is because of missing include in the sriov.pp

the code is:
class tripleo::profile::base::neutron::sriov(
  $step               = hiera('step'),
  $mechanism_drivers  = hiera('neutron::plugins::ml2::mechanism_drivers'),
) {

  if $step >= 4 {
    if 'sriovnicswitch' in $mechanism_drivers  {
      include ::neutron::agents::ml2::sriov
      include ::tripleo::host::sriov
    }
  }

}

which not including "::tripleo::profile::base::neutron" that responsible to configure neutron.conf which holds all the rabbit conf

to fix just modify to:
class tripleo::profile::base::neutron::sriov(
  $step               = hiera('step'),
  $mechanism_drivers  = hiera('neutron::plugins::ml2::mechanism_drivers'),
) {

  include ::tripleo::profile::base::neutron

  if $step >= 4 {
    if 'sriovnicswitch' in $mechanism_drivers  {
      include ::neutron::agents::ml2::sriov
      include ::tripleo::host::sriov
    }
  }
}

Comment 3 Vijay Chundury 2017-03-27 11:14:18 UTC
As mentioned this issue will be needed for ODL/SRIOV flows...
Nir, can this wait beyond OSP12 else request the ODL team to pick it up.

Comment 4 Nir Yechiel 2017-03-28 05:03:38 UTC
@Tim, looks like this issue may affect our ODL+SR-IOV use-case. Can you take a look for Pike?

Thanks,
Nir

Comment 10 errata-xmlrpc 2017-12-13 21:11:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.