Bug 142628 - A recent update changed my touch-pad settings
A recent update changed my touch-pad settings
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-10 20:00 EST by Alan Grover
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 02:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/yum.log (14.29 KB, text/plain)
2004-12-14 14:07 EST, Alan Grover
no flags Details
/var/log/boot.log (19.99 KB, text/plain)
2004-12-14 15:21 EST, Alan Grover
no flags Details
/etc/X11/xorg.conf (2.76 KB, text/plain)
2004-12-14 15:23 EST, Alan Grover
no flags Details
/var/log/dmesg (9.72 KB, text/plain)
2004-12-14 16:00 EST, Alan Grover
no flags Details

  None (edit)
Description Alan Grover 2004-12-10 20:00:29 EST
Description of problem:

A recent update (using yum) changed my touchpad settings.  I had set
the touchpad to not click via the pad.  The update turned that setting
back on.  

Please don't mess with my settings with your updates!  It is hard
enough to configure linix without having to recover from settings
changed by updates.

Version-Release number of selected component (if applicable):


How reproducible:

Dunno, since it happened during and update

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Paul Nasrat 2004-12-10 20:16:25 EST
Could you provide more data - how did you disable the touchpad? 
Please attach the output of rpm --last -qa so I can try and figure
what may have done this.  If you use yum please also attach
/var/log/yum.log.  Have you used any configuration tools - such as
system-config-display to set things up since you disabled the
touchpad.  Please attach your /etc/X11/xorg.conf along with an ls -al
/etc/X11 so I can at least try and figure out when your xorg.conf may
have changed.

I can't think of anything that an update without some additional steps
(eg system-config-display --reconfig) would prevent.
Comment 2 Alan Grover 2004-12-14 14:07:27 EST
Created attachment 108549 [details]
/var/log/yum.log
Comment 3 Alan Grover 2004-12-14 14:17:04 EST
The problem seems to be the new kernel in the update (2.6.9-1.6_FC2). 

I think I actually didn't have to do anything to disable the tapping
feature of the touchpad with FC2.  I used tpconfig to disable the
feature in RH9.  It may be that the new 2.6 kernel support for the
feature was not present or enabled by default.  So this update may be
a "fix".  Only now, as far as I am concerned, it is broken.  I have
tried using tpconfig again, but it does not work.  Even if I boot in
single user mode tpconfig just gives me an error that it can't open
the ps2 aux port.

Anyway, I tried the pre-update kernel (2.6.8-1.521), and tapping is
still disabled when I boot using that kernel.

Is there a way to disable the feature in the new kernel?

Comment 4 Paul Nasrat 2004-12-14 15:08:31 EST
You can play with the various psmouse.proto settings. Can you attach
your xorg.conf as requested, along with /var/log/boot.log
Comment 5 Alan Grover 2004-12-14 15:21:02 EST
Created attachment 108563 [details]
/var/log/boot.log
Comment 6 Alan Grover 2004-12-14 15:23:10 EST
Created attachment 108564 [details]
/etc/X11/xorg.conf
Comment 7 Paul Nasrat 2004-12-14 15:27:08 EST
Sorry one last file - can you attach /var/log/dmesg from booting with
the updated kernel.  

Also can you try booting with:

psmouse.proto=imps and see if that makes any difference.

Comment 8 Alan Grover 2004-12-14 16:00:30 EST
Created attachment 108568 [details]
/var/log/dmesg
Comment 9 Alan Grover 2004-12-14 16:04:42 EST
From what I can tell, the psmouse.proto=imps just selects a protocol.
 It doesn't configure options about things like the tapping settings
on a touchpad.  I tried it;  the behaviour is the same with or without
it.  It does not seem to help tpconfig access the touchpad. (Is that
what we were trying to accomplish?  I'm still pretty hazy about where
the settings are supposed to be located or twiddled.)
Comment 10 Paul Nasrat 2004-12-14 16:34:57 EST
IIRC we don't ship tpconfig, plus it's deprecated in favour of the
synaptics driver which we do ship in Fedora Core 3.

It looks as if the default kernel setup for tap click has changed. 
Changing the protocol disables extensions so with psmouse.proto=imps
you won't get raw events for synaptics driver, but that's not what you
are seeing.

Dave has anything in the input layer changed between:

2.6.9-1.6_FC2
2.6.8-1.521

That would affect this.
Comment 11 Dave Jones 2005-04-16 02:16:30 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.