Bug 1426341 - rear detects incorrect disk size on Advanced Format disks with a non-512 block size
Summary: rear detects incorrect disk size on Advanced Format disks with a non-512 bloc...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 7.7
Assignee: Pavel Cahyna
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks: 1420851 1630904 1630910 1660473
TreeView+ depends on / blocked
 
Reported: 2017-02-23 17:36 UTC by Kyle Walker
Modified: 2019-08-13 12:51 UTC (History)
3 users (show)

Fixed In Version: rear-2.4-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-13 12:51:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1610638 None None None 2019-10-21 19:04:05 UTC
Red Hat Knowledge Base (Solution) 2943451 None None None 2017-02-23 18:11:10 UTC

Internal Links: 1610638

Description Kyle Walker 2017-02-23 17:36:24 UTC
Description of problem:
 When detecting the disk layout for a system with Advanced Format (AF) disks, the size of the disk is incorrect. 

Version-Release number of selected component (if applicable):
 rear-1.17.2-6.el7

How reproducible:
 Easily, with the correct disks

Steps to Reproduce:
1. Install and configure rear for basic use including most/all local storage
2. Verify that one or more disks report a value greater than 512 for /sys/block/<disk>/queue/logical_block_size
3. Create a rescue image
4. Verify in the resulting disklayout.conf that the size of the disk is correct

Actual results:
 The disk will be reported as significantly larger than it actually is

Expected results:
 The disk will be reported as the correct size

Additional info:
 This is due to the use of the "logical_block_size" interface exposed by the kernel via the sysfs filesystem. The value found is used as the multiplier for the "size" interface. However, the "size" interface is always in 512 byte blocks. Regardless of the "logical_block_size".

Comment 5 Pavel Cahyna 2018-08-06 17:23:25 UTC
This is being worked on in bz1610638 (see the linked upstream PR).

Comment 7 Pavel Cahyna 2019-08-13 12:51:19 UTC
Fixed together with bz1610638 in RHBA-2019:2273 (RHEL 7.7).


Note You need to log in before you can comment on or make changes to this bug.