Bug 1426343 - Unable to rct cc candlepin-ca.pem using latest subscription-manager build from jenkins
Summary: Unable to rct cc candlepin-ca.pem using latest subscription-manager build fro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
: 1445511 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-23 17:39 UTC by Rehana
Modified: 2017-08-01 19:21 UTC (History)
6 users (show)

Fixed In Version: subscription-manager-1.19.11-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:21:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Rehana 2017-02-23 17:39:04 UTC
Description of problem:
install latest subscription-manager builds from jenkins ,copy the ca- cert to client n try to rct cc candlepin-ca.pem

Version-Release number of selected component (if applicable):
subscription management server: 2.0.26-1
subscription management rules: 5.21
subscription-manager: 1.19.1-1.git.10.02b3026.el6
python-rhsm: 1.19.1-1.git.3.9985682.el6

How reproducible:
Always 

Steps to Reproduce:
1.copy candlepin-ca.crt to client after deployment of the server
ex:  scp root@server:/etc/candlepin/certs/candlepin-ca.crt /etc/rhsm/ca/candlepin-ca.pem

2.# rct cc /etc/rhsm/ca/candlepin-ca.pem 
Unable to read certificate file '/etc/rhsm/ca/candlepin-ca.pem': 'NoneType' object has no attribute 'decode'


Actual results:
rct cat-cert fails with error 

Expected results:
user should be able to view the contents 

Additional info:

rhsm.log
===========
2017-02-23 12:34:44,336 [INFO] subscription-manager:7380:MainThread @connection.py:505 - Response: status=200, requestUuid=fbf81b91-b85f-43bb-9b7f-7a9f119d5415, request="GET /subscription/status"
2017-02-23 12:34:44,338 [INFO] subscription-manager:7380:MainThread @managercli.py:401 - Server Versions: {'rules-version': u'5.15.1', 'candlepin': u'0.9.51.21-1', 'server-type': 'This system is currently not registered.'}
2017-02-23 12:34:52,610 [ERROR] rct:7383:MainThread @certificate2.py:104 - 'NoneType' object has no attribute 'decode'
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/rhsm/certificate2.py", line 97, in _read_x509
    return self._create_v1_cert(version, extensions, x509, path)
  File "/usr/lib64/python2.6/site-packages/rhsm/certificate2.py", line 112, in _create_v1_cert
    return self._create_identity_cert(version, extensions, x509, path)
  File "/usr/lib64/python2.6/site-packages/rhsm/certificate2.py", line 135, in _create_identity_cert
    alt_name=self._read_alt_name(x509),
  File "/usr/lib64/python2.6/site-packages/rhsm/certificate2.py", line 119, in _read_alt_name
    return x509.get_extension(name='subjectAltName').decode('utf-8')
AttributeError: 'NoneType' object has no attribute 'decode'

Comment 5 Chris Snyder 2017-04-27 15:40:04 UTC
*** Bug 1445511 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2017-08-01 19:21:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.