Bug 142638 - mkreiserfs not present during install
Summary: mkreiserfs not present during install
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: reiserfs-utils (Show other bugs)
(Show other bugs)
Version: 3
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-11 09:47 UTC by Gabriel Schulhof
Modified: 2013-07-03 02:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 06:27:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gabriel Schulhof 2004-12-11 09:47:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040919

Description of problem:
When attempting to install with reiserfs turned on, and selecting a
partition for formatting, the python script crashes fatally right
after the package selection because it cannot find the mkreiserfs
command in order to create the file system.

Version-Release number of selected component (if applicable):
anaconda-10.1.0.2-1

How reproducible:
Always

Steps to Reproduce:
1. Start installing fc3-ppc
2. In Disk Druid, create/edit a reiserfs partition and tell the
installer to format it.
3. Move on past the package selection screen.
4. Watch the python debug box come up.  The bottom-most message says
that it cannot find "mkreiserfs"
    

Actual Results:  The installer crashes with a python traceback dialog box.

Expected Results:  The chosen filesystem gets formatted reiserfs, and
installation continues.

Additional info:

None.

Comment 1 Jeremy Katz 2004-12-14 01:50:34 UTC
The package doesn't exist for ppc

Comment 2 Gabriel Schulhof 2004-12-16 19:31:11 UTC
Which package ? reiserfs-utils ? Ummm .. my iBook was formatted
reiserfs before installing FC3, because I had Gentoo on it previously,
so reiserfs-utils is obviously available for PPC.

Maybe you were referring to anaconda not being available for ppc.  I
reported this bug against anaconda, because missing mkreiserfs was
causing the installation to crash and, AFAIK, anaconda is the name of
the program used to install FC. Either way, mkreiserfs should not be
absent during the installation, if reiserfs is in the combo box
containing different file system formats available to the person
installing.

Whether mkreiserfs or reiserfs-utils is present after the installation
is irrelevant to the installation itself.

I don't believe this is a problem with the reiserfs-utils package.
Rather, it is a bug in what is probably the stage2 installer image. 
This image should contain mkreiserfs, to prevent the installation
process from crashing when the user selects to format a partition
reiserfs.


Note You need to log in before you can comment on or make changes to this bug.