Bug 1426454 - Banshee fails to start, complains about dbus issues
Summary: Banshee fails to start, complains about dbus issues
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: mono
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavier Lamien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-23 23:45 UTC by Valdis Kletnieks
Modified: 2018-05-29 12:05 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-29 12:05:33 UTC


Attachments (Terms of Use)
Traceback of banshee crashing at startup. (20.15 KB, text/plain)
2017-02-23 23:45 UTC, Valdis Kletnieks
no flags Details

Description Valdis Kletnieks 2017-02-23 23:45:50 UTC
Created attachment 1257070 [details]
Traceback of banshee crashing at startup.

Description of problem:

After Fedora_26_Mass_Rebuild, banshee dies a few seconds after starting up, leaving a truly amazing traceback that implicates a dbus issue. 


Version-Release number of selected component (if applicable):
banshee-2.6.2-18.fc26.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tom "spot" Callaway 2017-02-27 18:32:31 UTC
I really think this is something in mono.

Comment 2 Valdis Kletnieks 2017-02-27 19:03:45 UTC
(In reply to Tom "spot" Callaway from comment #1)
> I really think this is something in mono.

Good catch, Tom.  Reverting to mono 4.6.2-5 fixed it, moving forward to 4.8.0 breaks it.  I was slowly working through which of the 600 updates that day broke it, but yeah, confirmed it was mono.

Comment 3 Fedora End Of Life 2017-02-28 12:25:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

Comment 4 Timotheus Pokorra 2017-03-07 08:17:14 UTC
was this fixed by the upgraded dbus-sharp package (https://admin.fedoraproject.org/pkgdb/package/rpms/dbus-sharp/).
Or does it still fail with dbus-sharp-0.8.1?

Comment 5 Timotheus Pokorra 2017-03-08 13:50:39 UTC
I have now filed a bug upstream: https://bugzilla.xamarin.com/show_bug.cgi?id=53154

Comment 6 Fedora End Of Life 2018-05-03 08:44:55 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 7 Fedora End Of Life 2018-05-29 12:05:33 UTC
Fedora 26 changed to end-of-life (EOL) status on 2018-05-29. Fedora 26
is no longer maintained, which means that it will not receive any
further security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.