Bug 1426517 - Additional mount option for glusterfs volume as backend for HE storage
Summary: Additional mount option for glusterfs volume as backend for HE storage
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.Gluster
Version: 2.1.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.2.2
: 2.2.10
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard: integration
Depends On: 1455169
Blocks: Gluster-HC-3 1458709
TreeView+ depends on / blocked
 
Reported: 2017-02-24 06:09 UTC by SATHEESARAN
Modified: 2019-04-28 14:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Interactively ask additional mount options for glusterfs volume if hosted-engine-setup is directly started without gdeploy
Clone Of:
Environment:
Last Closed: 2018-03-29 10:58:25 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
ylavi: exception+
rule-engine: planning_ack+
sbonazzo: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1402417 'high' 'CLOSED' 'Mount options are lost when storage is imported to the engine, please block it from the setup.' 2019-11-13 11:02:54 UTC
Red Hat Bugzilla 1434423 'unspecified' 'CLOSED' 'Mount options for the HE Gluster storage that will have the replica peers are not persisted in the database' 2019-11-13 11:02:54 UTC
Red Hat Bugzilla 1545145 'unspecified' 'CLOSED' '[testonly] Ensure that additional mount option for glusterfs volume are properly working also from cockpit UI' 2019-11-13 11:02:55 UTC
oVirt gerrit 74094 'None' MERGED gluster: query mount options only if on gluster 2020-06-30 08:59:40 UTC

Internal Links: 1402417 1434423 1545145

Description SATHEESARAN 2017-02-24 06:09:55 UTC
Description of problem:
------------------------
The additional mount options for glusterfs volume was not asked interactively with 'hosted-engine --deploy'. 

Gluster deployment is done through cockpit. The HostedEngine deployment is guided from Gluster deployment, as the additional config file is passed, which has the following:

# cat /tmp/he-answer.conf 
[environment:default]
OVEHOSTED_STORAGE/storageDomainConnection=str:host1:/engine
OVEHOSTED_STORAGE/mntOptions=str:backup-volfile-servers=host2:host3

But if the user has made some mistake with the hosted-engine setup, and restarts the 'HE standard deployment' again via cockpit, then there is no way to pass this additional mount options to the hosted-engine --deploy


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
ovirt-hosted-engine-setup-2.1.0.1-1.el7ev.noarch

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Start with Gluster deployment flow.
2. Continue with HE deployment
3. Close the HE deployment in the middle and start over again with 'Standard deployment'

Actual results:
---------------
additional mount options couldn't be passed 

Expected results:
-----------------
additional mount options should be passed to 'hosted-engine --deploy'

Additional info:
-----------------
The additional mount options is required for gluster volume, just to add the backup-volfile-servers. If the hosted-engine --deploy has this ability to deduce the backup-volfile-servers ( using 'gluster volume info' or anything related ) and uses it as additional mount options, then this requirement goes void.

Comment 1 SATHEESARAN 2017-02-24 06:15:22 UTC
Moving the product to 'RHV' as this issue is not seen with upstream ovirt-hosted-engine setup.

Comment 3 SATHEESARAN 2017-02-24 06:25:09 UTC
(In reply to SATHEESARAN from comment #1)
> Moving the product to 'RHV' as this issue is not seen with upstream
> ovirt-hosted-engine setup.

Apologies for the confusion, the issue exists in upstream oVirt as well.
Moving this bug back to oVirt

Comment 4 Ramesh N 2017-02-24 10:11:01 UTC
Considering Hosted-Engine deploy option in Cockpit UI doesn't have a provision to pass answer file, Can we ask the mount options in the interactive question? 

Note: When HE deployment is triggered from gdeploy wizard in Cockpit, mount options and other volume details passed through answer files. But the same thing is not possible when user 'Restart' the HE deployment in UI.

Comment 5 Simone Tiraboschi 2017-02-24 15:37:07 UTC
(In reply to Ramesh N from comment #4)
> Considering Hosted-Engine deploy option in Cockpit UI doesn't have a
> provision to pass answer file, Can we ask the mount options in the
> interactive question? 

This conflicts with https://bugzilla.redhat.com/1402417
Please consider reopening it.

Comment 6 Yaniv Lavi 2017-03-15 08:35:48 UTC
Don't we add this option ('backup-volfile-servers=host2:host3') to gluster in any case? I remember adding this feature in 3.6.

Comment 7 Tal Nisan 2017-03-15 10:15:26 UTC
I see Sahina added it on https://gerrit.ovirt.org/66306, perhaps she can shed more light on the subject

Comment 8 Ramesh N 2017-03-17 06:56:36 UTC
(In reply to Yaniv Dary from comment #6)
> Don't we add this option ('backup-volfile-servers=host2:host3') to gluster
> in any case? I remember adding this feature in 3.6.

We add mount options when user creates glusterfs storage domain from UI/Engine. But for hosted-engine, we requires this option in hosted-engine-setup. Currently mount option can be passed only through answer file in hosted-engine --deploy. But Hosted-Engine deployment in Cockpit doesn't allow user to pass answer files. So we need this option in interactive hosted-engine --deploy script.

Comment 9 Yaniv Lavi 2017-03-19 15:46:26 UTC
(In reply to Ramesh N from comment #8)
> (In reply to Yaniv Dary from comment #6)
> > Don't we add this option ('backup-volfile-servers=host2:host3') to gluster
> > in any case? I remember adding this feature in 3.6.
> 
> We add mount options when user creates glusterfs storage domain from
> UI/Engine. But for hosted-engine, we requires this option in
> hosted-engine-setup. Currently mount option can be passed only through
> answer file in hosted-engine --deploy. But Hosted-Engine deployment in
> Cockpit doesn't allow user to pass answer files. So we need this option in
> interactive hosted-engine --deploy script.

Why do you require it ans why do you not mind losing it in import of the HE SD?

Comment 10 Sahina Bose 2017-03-21 07:27:17 UTC
We do not want to lose the mount options while importing HE SD. In fact, these mount options need to be available for additional HE install on other hosts as well. 
The way I understand it, currently the HE mount options are present in he.conf file on each host, and as per Comment 2 are also stored in HE domain in database.

Is this not accurate?

Comment 11 Yaniv Lavi 2017-03-30 09:11:23 UTC
(In reply to Sahina Bose from comment #10)
> We do not want to lose the mount options while importing HE SD. In fact,
> these mount options need to be available for additional HE install on other
> hosts as well. 
> The way I understand it, currently the HE mount options are present in
> he.conf file on each host, and as per Comment 2 are also stored in HE domain
> in database.
> 
> Is this not accurate?

No, the way it works is that the engine queries the peers for the Gluster volume when adding the SD. Not when you import the HE storage. 
I gave the test steps on BZ #1434423.

Comment 13 Sandro Bonazzola 2017-06-01 07:13:44 UTC
Moving to 4.2 since the bug #1373930 has been targeted to 4.2 and this one depend on it.

Comment 14 Yaniv Kaul 2017-10-15 09:20:13 UTC
(In reply to Sandro Bonazzola from comment #13)
> Moving to 4.2 since the bug #1373930 has been targeted to 4.2 and this one
> depend on it.

Moving to ASSIGNED for the time being.

Comment 15 Simone Tiraboschi 2018-02-14 10:45:56 UTC
Everything should be there on hosted-engine-setup side for the vintage flow and for the new one.
I'll open a test only BUG on cockpit to ensure that everything is there as well.

Comment 16 Nikolai Sednev 2018-02-18 12:56:58 UTC
Is this a HC specific?

Comment 17 Simone Tiraboschi 2018-02-19 08:57:52 UTC
(In reply to Nikolai Sednev from comment #16)
> Is this a HC specific?

No, it should work also for gluster on external hosts although it's by far more relevant on HC.

Comment 18 Nikolai Sednev 2018-03-20 14:17:10 UTC
[ INFO  ] changed: [localhost]
          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: glusterfs
          Please specify the full shared storage connection path to use (example: host:/path): gluster01.scl.lab.tlv.redhat.com:/nsednev_he_1
          If needed, specify additional mount options for the connection to the hosted-engine storagedomain []: backup-volfile-servers=gluster02.scl.lab.tlv.redhat.com:gluster03.scl.lab.tlv.redhat.com
[ INFO  ] Creating Storage Domain
[ INFO  ] TASK [Gathering Facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [include_tasks]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Obtain SSO token using username/password credentials]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch host facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch cluster id]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch cluster facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch datacenter facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch datacenter id]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Fetch datacenter_name]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Add nfs storage domain]
[ INFO  ] skipping: [localhost]
[ INFO  ] TASK [Add glusterfs storage domain]
^C          Please specify the storage you would like to use (glusterfs, iscsi, fc, nfs)[nfs]: glusterfs
          Please specify the full shared storage connection path to use (example: host:/path): gluster01.scl.lab.tlv.redhat.com:/nsednev_he_1
          If needed, specify additional mount options for the connection to the hosted-engine storagedomain []: backup-volfile-servers=gluster02.scl.lab.tlv.redhat.com:gluster03.scl.lab.tlv.redhat.com
[ INFO  ] Creating Storage Domain
[ INFO  ] TASK [Gathering Facts]

Deployment was interrupted manually and then I've got again gluster storage option and received mount options again.

Works for me forth to provided reproduction steps.
ovirt-hosted-engine-ha-2.2.7-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.13-1.el7ev.noarch
rhvm-appliance-4.2-20180202.0.el7.noarch
Linux 3.10.0-861.el7.x86_64 #1 SMP Wed Mar 14 10:21:01 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)

Moving to verified.

Comment 19 Sandro Bonazzola 2018-03-29 10:58:25 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.