Bug 142655 - fix scriptlets so they check for a mounted /proc
fix scriptlets so they check for a mounted /proc
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-11 14:55 EST by Sunny Dubey
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 11:26:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sunny Dubey 2004-12-11 14:55:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; en_US) (KHTML, like Gecko)

Description of problem:
Fix the iptables scriptlet so that it checks for a mounted /proc before issuing any commands.  (This is to prevent from a chroot()'ed install of iptables from issuing commands that might affect the host).

IRC conversation with jbj@redhat as follows;


<jbj> iptables shares global state in the kerenl in spite of chroot. the fix will be to change the scriptlet somehow
<jbj> so scriptlet running in chroot changes the kernel table.
<jbj> perhaps quick and dirty test for /proc mounted in scriptlet is easiest.
<jbj> presuming that /proc is not mounted in chroot.
<jbj> a real test for running in chroot will perhaps need changes to rpm.
<jbj> RFE at bugzilla.redhat.com please so that I don't forget.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
rpm -ivh iptables* --root /path
    

Actual Results:  iptables will install ... and the scriptlets will be run (which may cause issues on the host, because they are really being run on the host).

Additional info:
Comment 1 Thomas Woerner 2004-12-20 08:59:54 EST
%post only triggers a "/sbin/chkconfig --add iptables".

Where exactly is the problem?
Comment 2 Sunny Dubey 2004-12-25 10:27:34 EST
Beats me,     
     
this was jbj's idea and he requested I submit this bug. 
Comment 3 Thomas Woerner 2005-03-18 11:26:59 EST
Closing as NOT A BUG.

Note You need to log in before you can comment on or make changes to this bug.