This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 142657 - /etc/mozpluggerrc not adjusted to FC3 "realities"
/etc/mozpluggerrc not adjusted to FC3 "realities"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mozplugger (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-11 16:52 EST by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 13:59:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-12-11 16:52:25 EST
Description of problem:

/etc/mozpluggerrc delegates actions to various programs which
are not likely to be available on a system.  While it can be
expected that at lest some of these can be installed later from
"outside sources" a something which has better chances to work
right away would be nice.

For example 'xanim' seems to mostly vanished.  What instead?
First choice for tiff files is 'gqview', followed by 'xv', while
'gthumb' is not  mentioned at all (could be used?).  'acroread'
instead of 'xpdf' or 'gpdf' opens up a list of apps for pdf handling.
There is 'gv' and 'pageview' for Postcript files but no 'ggv'.
'realplay' is supposed to handle various realaudio streams
instead of 'hxplay'.  In the last case one likely has already
nphelix.so, which will take over the job, but if yes then maybe
/etc/mozpluggerrc should have a relevant comment instead?

There is a chance that I will edit that file anyway but it would
be nice if one would need less of such editing.

Version-Release number of selected component (if applicable):
mozplugger-1.6.2-1
Comment 1 Ngo Than 2006-05-16 13:59:51 EDT
:wqI have already adjusted the /etc/mozpluggerrc for FC5 release. It should now
work better. For Xanim, i have not found the replacement yet, but it does not hurt
if it still stays in the config file.
I still prefer Helixplayer because it's included in FC release.
Comment 2 Michal Jaegermann 2006-05-16 14:24:52 EDT
> I still prefer Helixplayer because it's included in FC release.

The problem was, of course, that at the time of the original report
mozplugger expected to find RealPlayer.  Yes, /etc/mozpluggerrc did
change quite substantially from the one availble in 2004.

'xine' will play various files which 'xanim' used to - or at least some
of them.  I know that it is not in a distro but at least possible
to fine.  The current /etc/mozpluggerrc will actually try 'mplayer',
'totem' or 'xine' for various video files.

Note You need to log in before you can comment on or make changes to this bug.