Bug 142658 - xemacs fonts appear to be limited
xemacs fonts appear to be limited
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-11 18:05 EST by Yaron Minsky
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 10:18:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaron Minsky 2004-12-11 18:05:21 EST
Description of problem:
Various fonts on the system that should work with xemacs (and that
did, in, for example, FC2) no longer do.  For instance,
lucidatypewriter, which exists and comes up in other contexts (for
instance, in gedit), no longer works with xemacs.  

Version-Release number of selected component (if applicable):

How to reproduce:
Start up xemacs, observe that in the options->font pulldown menu, few
fonts show up, and in particular, lucidatypewriter doesn't come up. 
Similarly, try to set the font of the default face to something
reasonable, like:

 -*-lucidatypewriter-medium-*-*-*-*-100-*-*-*-*-*-*

And nothing happens.  Other fonts, such as Fixed, do appear to work.
Comment 1 Jens Petersen 2005-01-24 08:28:41 EST
Any differences in the output of xlsfonts say?
Comment 2 Yaron Minsky 2005-01-24 11:24:26 EST
xlsfonts on both FC1 and FC3 machines I have access to list lucidatypewriter
fonts, but on FC3, xemacs doesn't see them.  Does that answer the question?
Comment 3 Ville Skyttä 2005-04-14 17:26:39 EDT
Hmm, I'm unable to reproduce with 21.4.15-9 on FC3 and 21.4.17-2 on FC3 and
FC4t2; as far as I can tell, all fonts that should, do show up in the
Options->Font menu and work as expected (including lucidatypewriter).

How are you trying to set the default font face?

Jens, do you think configuring using --with-xfs=no could affect this?
Comment 4 Jens Petersen 2005-04-19 03:33:36 EDT
I don't know, sorry.
Comment 5 Yaron Minsky 2005-04-19 07:24:50 EDT
Interesting.  I can't reproduce the problem anymore either!  Some other update
must have fixed it in the meantime, though I don't know what.
Comment 6 Ville Skyttä 2005-04-19 10:18:13 EDT
Thanks for the update.  I'm closing this bug at least for now; if the problem
resurfaces, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.