Bug 142671 - hald segmentation fault
hald segmentation fault
Status: CLOSED DUPLICATE of bug 142183
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-12 06:11 EST by Federico
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hald verbose output (168.17 KB, text/plain)
2004-12-12 06:14 EST, Federico
no flags Details

  None (edit)
Description Federico 2004-12-12 06:11:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Whenever hald deamon runs it crashes after few seconds. This is the
last part of the verbose messages:

11:36:41.465 [I] linux/osspec.c:793: handling /sys/class/net/lo net
11:36:41.465 [I] linux/osspec.c:793: handling /sys/class/net/eth0 net
11:36:41.584 [E] linux/net_class_device.c:137: SIOCGMIIREG on eth0
failed: Bad address

11:36:41.584 [E] linux/net_class_device.c:137: SIOCGMIIREG on eth0
failed: Bad address

11:36:41.584 [W] linux/net_class_device.c:257: Error reading link info
11:36:41.584 [E] linux/net_class_device.c:137: SIOCGMIIREG on eth0
failed: Bad address

11:36:41.584 [W] linux/net_class_device.c:193: Error reading rate info
Segmentation fault



Version-Release number of selected component (if applicable):
hal-0.4.2-1.FC3

How reproducible:
Always

Steps to Reproduce:
1. run hald (from services or from terminal)

    

Actual Results:  Segmentation fault.


Expected Results:  Deamon to run in background with no problems.


Additional info:
Comment 1 Federico 2004-12-12 06:14:02 EST
Created attachment 108400 [details]
hald verbose output

In the log file you cant see but after last error the deamon crashes:

11:36:41.584 [W] linux/net_class_device.c:193: Error reading rate info
Segmentation fault
Comment 2 David Zeuthen 2004-12-12 12:59:02 EST

*** This bug has been marked as a duplicate of 142183 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.