Bug 142673 - Improved man2html page translation.
Improved man2html page translation.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-12 07:05 EST by DaveG
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-23 01:54:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Simple improvements for man2html. (1.09 KB, patch)
2004-12-12 07:08 EST, DaveG
no flags Details | Diff

  None (edit)
Description DaveG 2004-12-12 07:05:02 EST
Description of problem:

The man2html component in the man package has a few wrinkles that can 
easily be fixed:
a. table handling
b. hyperlinks to header files
c. hyperlink recognition for Perl modules

Version-Release number of selected component (if applicable):

Present in all versions of man since RHL72.

How reproducible:

Steps to Reproduce:
1. Set up man2html CGI scripts as per man2html documentation.
2. Use a web browser to access standard manual pages for fetchmail
(1), syslog(2) and spamassassin(1). These are the pages that prompted 
this report.
3. Look at the results.
  
Actual results:

fetchmail: "Keyword/Option Summary" - entries illegible.
syslog: "#include <sys/klog.h>" - 
href="file:///usr/include/sys/klog.h"
spamassassin: "SEE ALSO", "Mail::SpamAssassin::Conf(3)" 
href="http://www.localnet/cgi-bin/man/man2html?3+Conf"

Expected results:

fetchmail: table layout legible.
syslog: href for include files should be http://<server>/include/...
spamassassin: should include ":" as valid man page character.

Additional info:

Changes can be accomplished with just 10 lines of code - see attached 
patch.
Comment 1 DaveG 2004-12-12 07:08:50 EST
Created attachment 108401 [details]
Simple improvements for man2html.
Comment 2 Ivana Varekova 2005-03-22 03:05:14 EST
Thank you for notice and your patch. I used your patch to fix these problems (I
used only first and third changes. I think the original format of address in the
second item is correct.)
The fixed version is 1.5p-3.
Ivana Varekova

Note You need to log in before you can comment on or make changes to this bug.