Bug 1426836 - systemd-modules-load.service failed because the control process exited with error code.
Summary: systemd-modules-load.service failed because the control process exited with e...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-25 14:16 UTC by William Moreno
Modified: 2017-03-01 15:28 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-01 15:28:24 UTC
Type: Bug


Attachments (Terms of Use)

Description William Moreno 2017-02-25 14:16:15 UTC
Description of problem:
systemd-modules-load fail to load kernel modules in all versions of the kernel

akmods
Checking kmods exist for 4.9.12-200.fc25.x86_64            [  OK  ]

systemctl start systemd-modules-load.service
Job for systemd-modules-load.service failed because the control process exited with error code.
See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.

status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static;
   Active: failed (Result: exit-code) since sáb 2017-02-25 08:14:00 CST; 25s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 2505 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, st
 Main PID: 2505 (code=exited, status=1/FAILURE)

feb 25 08:14:00 sesshomaru systemd[1]: Starting Load Kernel Modules...
feb 25 08:14:00 sesshomaru systemd[1]: systemd-modules-load.service: Main proces
feb 25 08:14:00 sesshomaru systemd[1]: Failed to start Load Kernel Modules.
feb 25 08:14:00 sesshomaru systemd[1]: systemd-modules-load.service: Unit entere
feb 25 08:14:00 sesshomaru systemd[1]: systemd-modules-load.service: Failed with
lines 1-13/13 (END)...skipping...
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since sáb 2017-02-25 08:14:00 CST; 25s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 2505 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 2505 (code=exited, status=1/FAILURE)

feb 25 08:14:00 sesshomaru systemd[1]: Starting Load Kernel Modules...
feb 25 08:14:00 sesshomaru systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
feb 25 08:14:00 sesshomaru systemd[1]: Failed to start Load Kernel Modules.
feb 25 08:14:00 sesshomaru systemd[1]: systemd-modules-load.service: Unit entered failed state.
feb 25 08:14:00 sesshomaru systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.

Version-Release number of selected component (if applicable):
systemd-231-12.fc25.x86_64
kernel-4.9.10-200.fc25.x86_64
kernel-4.9.11-200.fc25.x86_64
kernel-4.9.12-200.fc25.x86_64

How reproducible:
systemctl start systemd-modules-load.service

Steps to Reproduce:
1. systemctl start systemd-modules-load.service

Comment 1 William Moreno 2017-03-01 15:28:24 UTC
Fixed with a selinux update


Note You need to log in before you can comment on or make changes to this bug.