Bug 142694 - fuser reports pids from root device when run on cd burner
Summary: fuser reports pids from root device when run on cd burner
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: psmisc   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-12 23:38 UTC by James Lopeman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-14 15:01:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Lopeman 2004-12-12 23:38:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
fuser -m / and fuser -m /media/cdrecorder
produce identical results

therefore fuser -km /media/cdrecoder
when issued by root unexpectedly kills init

Version-Release number of selected component (if applicable):
psmisc-21.4-4

How reproducible:
Always

Steps to Reproduce:
1. as root fuser -km /media/cdrecorder
2. reboot
3. alternatly compair fuser -m / and fuser -m /media/cdrecorder
    

Actual Results:  system crash from init being killed

Expected Results:  processes using /media/cdrecorder devicde being killed

Additional info:

Comment 1 Karel Zak 2004-12-14 11:02:29 UTC
Are you really really sure that /media/cdrecorder was mount point in
time when you called "fuser"?

fuser -m <dir>

  -- <dir> must be used mount point, else it reports all processes
that use filesystem where <dir> is defined.

Sorry, but it's feature, not a bug.

Example:

# mount | grep media
/dev/hdc on /media/cdrom type iso9660 (ro,nosuid,nodev,user=zakkr)

# fuser -m /media/cdrom
/media/cdrom:        15452c

# umount /media/cdrom

# fuser -m /media/cdrom
/media/cdrom:            1rce     2rc     3rc     4rc     5rc  





Comment 2 James Lopeman 2004-12-14 15:01:47 UTC
You are correct, it is just a feature. 
 
When the cdrom is mounted the out is as I expected. 
 
The only bug here is the chair-keyboard interface :) 


Note You need to log in before you can comment on or make changes to this bug.