Bug 142697 - Network link status changes provoke no further action
Network link status changes provoke no further action
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-12 20:04 EST by Tethys
Modified: 2014-03-16 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-14 12:37:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2004-12-12 20:04:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
When plugging in a network cable, the kernel detects the new
link, but no further action is taken


Version-Release number of selected component (if applicable):
hotplug-2004_04_01-8

How reproducible:
Always

Steps to Reproduce:
1. Boot machine with network cable unplugged
2. Once booted, plug in network cable
3.
    

Actual Results:  The kernel logs the link state change:

Dec 13 00:47:04 localhost kernel: b44: eth0: Link is up at 100 Mbps,
full duplex.
Dec 13 00:47:04 localhost kernel: b44: eth0: Flow control is on for TX
and on for RX.

But that's all.


Expected Results:  It should trigger that interface to be configured
(e.g., an ifup eth0). On most machines, that would cause
dhclient to be invoked to try and get an IP address. As it
stands, if you boot without the network cable connected, you're
screwed unless you know enough to do a "service network restart"
from the command line after reconnecting the cable.


Additional info:

Logging this against hotplug as it's the closest to an appropriate
place I can think of.
Comment 1 Bill Nottingham 2004-12-13 20:40:50 EST
You may want to try the NetworkManager package; it handles things like
this.
Comment 2 Tethys 2004-12-14 04:33:37 EST
Not really suitable. From the README:

>It is intended only for the desktop use-case, and is not intended
>for usage on servers.

Since I'm wanting to do this on a headless box, it doesn't look like
NetworkManager is a solution to the problem.
Comment 3 Bill Nottingham 2004-12-14 12:00:52 EST
There is also netplugd, part of net-tools.
Comment 4 Tethys 2004-12-14 12:37:36 EST
That looks much better (even if it launches a DoS on my filesystem
by filling up /var/log/messages -- but that's a separate bug :-)
I'd still have expected this to be hotplug, rather than requiring
a separate daemon, but it works, which is all I'm bothered about
right now.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.