Bug 142704 - page allocation failure - pwc Failed to allocate decompress table
page allocation failure - pwc Failed to allocate decompress table
Status: CLOSED DUPLICATE of bug 159608
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-12 22:08 EST by Lonni J Friedman
Modified: 2015-01-04 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 01:17:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lonni J Friedman 2004-12-12 22:08:30 EST
Description of problem:
I've got a Philips USB webcam that i've been using to grab snapshots
via a cronjob.  Its been working flawlessly for the past 2 weeks, when
all of a sudden this afternoon the cronjob started blowing up and
failing to capture images.  


Version-Release number of selected component (if applicable):
2.6.9-1.681_FC3

I'm using vgrabbj to capture the pictures, but this failure looks to
be coming from the pwc module.
  
Actual results:
The cronjob fails with this error:
Can't open "/dev/video0" as VideoDevice!
Fatal Error (non-daemon), exiting...

However, in the messages log & dmesg I see:

vgrabbj: page allocation failure. order:4, mode:0xd0
 [<02147206>] __alloc_pages+0x28b/0x298
 [<0214722b>] __get_free_pages+0x18/0x24
 [<0214a939>] kmem_getpages+0x15/0x94
 [<0214b6c5>] cache_grow+0x155/0x29a
 [<0214ba17>] cache_alloc_refill+0x20d/0x23d
 [<0214bc9f>] kmem_cache_alloc+0x46/0x4c
 [<12a71250>] pwc_allocate_buffers+0x1bd/0x292 [pwc]
 [<12a723e4>] pwc_video_open+0x196/0x334 [pwc]
 [<1298f187>] video_open+0xf1/0x170 [videodev]
 [<0217068e>] chrdev_open+0x3bd/0x458
 [<02164c5e>] dentry_open+0xbd/0x180
 [<02164b9b>] filp_open+0x36/0x3c
 [<021650b1>] sys_open+0x31/0x7d
pwc Failed to allocate decompress table.

Expected results:
No errors
Comment 1 Dave Jones 2005-02-12 23:28:42 EST
still a problem in the latest updates ?
Comment 2 Lonni J Friedman 2005-06-21 21:54:15 EDT
Sorry for the delayed response.  This did go away after the update, but is now
back in the kernel that shipped in FC4.  Interestingly, building and installing
version 10.0.7a of the pwc driver from here:
http://www.saillard.org/linux/pwc/files/pwc-10.0.7a.tar.bz2

fixed it.  So perhaps the version of pwc shipping with 2.6.11-1.1369_FC4 is
buggy? *shrug*
Comment 3 Joe Acosta 2005-07-10 18:28:42 EDT
Yes the FC4 kernels and pwc are buggy to say the least.  I did the same thing
with the kernel-2.6.12-1.1390_FC4.  I tried both camE and camsteam and got grey
image.  The grabbed 10.0.7a and now it works again.  

Comment 4 Dave Jones 2005-07-15 17:42:28 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 5 Rahul Sundaram 2005-09-05 01:17:07 EDT

*** This bug has been marked as a duplicate of 159608 ***

Note You need to log in before you can comment on or make changes to this bug.