Bug 1427046 - undercloud_public_host not in network_cidr
Summary: undercloud_public_host not in network_cidr
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Ben Nemec
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: 1437585
TreeView+ depends on / blocked
 
Reported: 2017-02-27 08:22 UTC by yfried
Modified: 2017-05-17 20:02 UTC (History)
12 users (show)

Fixed In Version: instack-undercloud-6.0.0-5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1437585 (view as bug list)
Environment:
Last Closed: 2017-05-17 20:02:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 450285 None None None 2017-03-27 15:19:24 UTC
OpenStack gerrit 451858 None None None 2017-03-30 15:12:47 UTC
Launchpad 1586158 None None None 2017-02-27 08:23:29 UTC
Launchpad 1668180 None None None 2017-02-27 08:22:53 UTC

Description yfried 2017-02-27 08:22:54 UTC
Description of problem:

As a user, I would like to access the undercloud API (UI or CLI) from a remote host, outside of the PXE booting subnet (i.e. a machine NOT managed by the undercloud)

Specifying such address in "undercloud_admin_host" is currently not allowed.

This is problematic, because in most scenarios, the overcloud's PXE subnet is the least likely place for a user to be in.


Version-Release number of selected component (if applicable):
11

How reproducible:
In undercloud.conf follow $subject:

undercloud_public_vip = 10.35.65.52
network_cidr = 192.168.24.0/24

Actual results:
stdout: 2017-02-27 02:50:40,257 INFO: Logging to /home/stack/.instack/install-undercloud.log
2017-02-27 02:50:40,270 INFO: Checking for a FQDN hostname...
2017-02-27 02:50:40,297 INFO: Static hostname detected as ironic-0.redhat.local
2017-02-27 02:50:40,306 INFO: Transient hostname detected as ironic-0.redhat.local
2017-02-27 02:50:40,307 ERROR: Undercloud configuration validation failed: undercloud_public_host "10.35.65.52" not in defined CIDR "192.168.24.0/24"
2017-02-27 02:50:40,307 ERROR:
#############################################################################
Undercloud install failed.

Reason: undercloud_public_host "10.35.65.52" not in defined CIDR "192.168.24.0/24"

See the previous output for details about what went wrong. The full install
log can be found at /home/stack/.instack/install-undercloud.log.

#############################################################################

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 1425, in install
    _validate_configuration()
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 683, in _validate_configuration
    _validate_network()
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 646, in _validate_network
    validator.validate_config(params, error_handler)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/validator.py", line 33, in validate_config
    _validate_in_cidr(local_params, error_callback)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/validator.py", line 99, in _validate_in_cidr
    require_ip=False)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/validator.py", line 81, in validate_addr_in_cidr
    error_callback(message)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 643, in error_handler
    raise validator.FailedValidation(message)
instack_undercloud.validator.FailedValidation: undercloud_public_host "10.35.65.52" not in defined CIDR "192.168.24.0/24"
Command 'instack-install-undercloud' returned non-zero exit status 1



Expected results:
Undercloud should be up with API (stackrc) and UI listening on specified address.

Comment 3 yfried 2017-03-14 23:40:37 UTC
How about - before running verification, check if address is assigned to an actual NIC on machine?
Can we use "import netifaces" in tripleo code?
This would make for a very simple fix without breaking anything

Comment 4 Emilien Macchi 2017-03-27 15:27:58 UTC
Patch has been merged master upstream (and currently being backported in upstream stable/ocata).

Moving it to POST until next donwstream build that contains the fix.

Comment 10 Jon Schlueter 2017-04-03 15:23:06 UTC
dropping upstream/master patch which has the stable/ocata backport and attached as external tracker

Comment 13 Gurenko Alex 2017-05-10 07:19:02 UTC
Passes validation on RC build

Comment 14 errata-xmlrpc 2017-05-17 20:02:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.