Bug 1427174 - Mesa 13+ breaks Xvnc (and similar X servers)
Summary: Mesa 13+ breaks Xvnc (and similar X servers)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa   
(Show other bugs)
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1399357 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-27 14:10 UTC by Pierre Ossman
Modified: 2017-04-01 17:18 UTC (History)
13 users (show)

Fixed In Version: mesa-13.0.4-3.fc25 mesa-17.0.2-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-24 18:55:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pierre Ossman 2017-02-27 14:10:32 UTC
Upgrade of mesa from 12.0.3-3.fc25 to 13.0.4-1.fc25 breaks GLX in Xvnc and ThinLinc (and probably other stuff with a similar design).

After upgrade:

> $ glxinfo
> name of display: :2
> Error: couldn't find RGB GLX visual or fbconfig

Upstream report:

https://bugs.freedesktop.org/show_bug.cgi?id=99987

glvnd fallout?

Comment 1 Norman Gaywood 2017-02-28 06:21:24 UTC
x2go also broken with (at least) an xfce4 desktop.

xfce4 session starts, but many programs won't start from the menus.

xterm starts from menus and we get:
> $ glxinfo
> name of display: :50.0
> Error: couldn't find RGB GLX visual or fbconfig

And things like:
> $ xfce4-terminal 
> Segmentation fault (core dumped)

> $ gnome-terminal
> Segmentation fault (core dumped)

For gnome-terminal:

ccpp-2017-02-28-17:16:40-2101 # gdb /usr/bin/gnome-terminal ./coredump
GNU gdb (GDB) Fedora 7.12.1-46.fc25
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/gnome-terminal...Reading symbols from /usr/lib/debug/usr/bin/gnome-terminal.debug...done.
done.
[New LWP 2101]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `gnome-terminal'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007fb111ac935f in rawmemchr () from /lib64/libc.so.6
Missing separate debuginfos, use: dnf debuginfo-install at-spi2-atk-2.22.0-1.fc25.x86_64 at-spi2-core-2.22.0-1.fc25.x86_64 atk-2.22.0-1.fc25.x86_64 bzip2-libs-1.0.6-21.fc25.x86_64 cairo-1.14.8-1.fc25.x86_64 cairo-gobject-1.14.8-1.fc25.x86_64 dbus-libs-1.11.10-1.fc25.x86_64 dconf-0.26.0-1.fc25.x86_64 expat-2.2.0-1.fc25.x86_64 fontconfig-2.12.1-1.fc25.x86_64 freetype-2.6.5-1.fc25.x86_64 gdk-pixbuf2-2.36.5-1.fc25.x86_64 glib2-2.50.3-1.fc25.x86_64 glibc-2.24-4.fc25.x86_64 gmp-6.1.1-1.fc25.x86_64 gnutls-3.5.9-2.fc25.x86_64 graphite2-1.3.6-1.fc25.x86_64 gtk3-3.22.8-1.fc25.x86_64 harfbuzz-1.3.2-1.fc25.x86_64 libNX_Xinerama-3.5.0.32-4.fc24.x86_64 libX11-1.6.4-4.fc25.x86_64 libXau-1.0.8-6.fc24.x86_64 libXcomposite-0.4.4-8.fc24.x86_64 libXcursor-1.1.14-6.fc24.x86_64 libXdamage-1.1.4-8.fc24.x86_64 libXext-1.3.3-4.fc24.x86_64 libXfixes-5.0.3-1.fc25.x86_64 libXi-1.7.9-1.fc25.x86_64 libXrandr-1.5.1-1.fc25.x86_64 libXrender-0.9.10-1.fc25.x86_64 libblkid-2.28.2-2.fc25.x86_64 libcap-2.25-2.fc25.x86_64 libdatrie-0.2.9-3.fc25.x86_64 libepoxy-1.3.1-3.fc25.x86_64 libffi-3.1-9.fc24.x86_64 libgcc-6.3.1-1.fc25.x86_64 libgcrypt-1.6.6-1.fc25.x86_64 libglvnd-0.2.999-10.gitdc16f8c.fc25.x86_64 libglvnd-egl-0.2.999-10.gitdc16f8c.fc25.x86_64 libglvnd-glx-0.2.999-10.gitdc16f8c.fc25.x86_64 libgpg-error-1.24-1.fc25.x86_64 libidn2-0.16-1.fc25.x86_64 libmount-2.28.2-2.fc25.x86_64 libpng-1.6.27-1.fc25.x86_64 libselinux-2.5-13.fc25.x86_64 libstdc++-6.3.1-1.fc25.x86_64 libtasn1-4.10-1.fc25.x86_64 libthai-0.1.25-1.fc25.x86_64 libunistring-0.9.4-3.fc24.x86_64 libuuid-2.28.2-2.fc25.x86_64 libwayland-client-1.12.0-1.fc25.x86_64 libwayland-cursor-1.12.0-1.fc25.x86_64 libxcb-1.12-1.fc25.x86_64 libxkbcommon-0.7.1-1.fc25.x86_64 lz4-1.7.5-1.fc25.x86_64 mesa-libwayland-egl-13.0.4-1.fc25.x86_64 nettle-3.3-1.fc25.x86_64 p11-kit-0.23.2-2.fc24.x86_64 pango-1.40.3-1.fc25.x86_64 pcre-8.40-4.fc25.x86_64 pcre2-10.23-1.fc25.x86_64 pixman-0.34.0-2.fc24.x86_64 systemd-libs-231-14.fc25.x86_64 vte291-0.46.1-1.fc25.x86_64 xz-libs-5.2.2-2.fc24.x86_64 zlib-1.2.8-10.fc24.x86_64
(gdb) where
#0  0x00007fb111ac935f in rawmemchr () at /lib64/libc.so.6
#1  0x00007fb111ab1832 in _IO_str_init_static_internal () at /lib64/libc.so.6
#2  0x00007fb111a9ecc7 in __isoc99_vsscanf () at /lib64/libc.so.6
#3  0x00007fb111a9ec67 in __isoc99_sscanf () at /lib64/libc.so.6
#4  0x00007fb10f6388e2 in epoxy_glx_version () at /lib64/libepoxy.so.0
#5  0x00007fb1143321e9 in gdk_x11_screen_init_gl () at /lib64/libgdk-3.so.0
#6  0x00007fb11433259a in _gdk_x11_screen_update_visuals_for_gl () at /lib64/libgdk-3.so.0
#7  0x00007fb11433b1f6 in _gdk_x11_screen_init_visuals () at /lib64/libgdk-3.so.0
#8  0x00007fb114338230 in _gdk_x11_screen_new () at /lib64/libgdk-3.so.0
#9  0x00007fb1143280c8 in _gdk_x11_display_open () at /lib64/libgdk-3.so.0
#10 0x00007fb1142fcb85 in gdk_display_manager_open_display () at /lib64/libgdk-3.so.0
#11 0x00007fb1147e6f26 in post_parse_hook () at /lib64/libgtk-3.so.0
#12 0x00007fb112a422d8 in g_option_context_parse () at /lib64/libglib-2.0.so.0
#13 0x000055943ba35834 in terminal_options_parse (working_directory=<optimized out>, startup_id=<optimized out>, argcp=0x7fff9a4ec93c, argvp=0x7fff9a4ec930, error=0x7fff9a4ec940) at terminal-options.c:868
#14 0x000055943ba3237a in main (argc=<optimized out>, argv=<optimized out>) at terminal.c:375
(gdb)

Comment 2 Norman Gaywood 2017-02-28 22:44:55 UTC
The work-around I'm using at the moment is to:

dnf downgrade mesa-libGL --allowerasing

Comment 3 Reilly Hall 2017-03-06 15:06:28 UTC
I too started experiencing this issue since last Monday after receiving the Mesa related updates (and new dependencies) sometime during the weekend just before that Monday.

I am interested in receiving updates related to this bug, as I run an XFCE4 desktop via x2go almost everyday.

Thanks.

Comment 4 JM 2017-03-07 01:14:39 UTC
Same problem here wie Mesa 13, downgrade to Mesa 12 solved the problem for the moment.

Comment 5 Bradi 2017-03-08 02:15:16 UTC
(In reply to Norman Gaywood from comment #2)
> The work-around I'm using at the moment is to:
> 
> dnf downgrade mesa-libGL --allowerasing

I am unable to use the workaround mentioned by Norman as I am unable to downgrade.

# sudo dnf downgrade mesa-libGL --allowerasing
Last metadata expiration check: 0:04:29 ago on Wed Mar  8 14:59:42 2017.
Dependencies resolved.
================================================================================
 Package          Arch      Version                           Repository   Size
================================================================================
Removing:
 libglvnd-glx     x86_64    1:0.2.999-10.gitdc16f8c.fc25      @updates    637 k
Downgrading:
 mesa-libGL       x86_64    12.0.3-3.fc25                     fedora      158 k
 mesa-libGLES     x86_64    12.0.3-3.fc25                     fedora       30 k
 mesa-libglapi    x86_64    12.0.3-3.fc25                     fedora       49 k

Transaction Summary
================================================================================
Remove     1 Package
Downgrade  3 Packages

Total size: 236 k
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] mesa-libGL-12.0.3-3.fc25.x86_64.rpm: Already downloaded
[SKIPPED] mesa-libglapi-12.0.3-3.fc25.x86_64.rpm: Already downloaded
[SKIPPED] mesa-libGLES-12.0.3-3.fc25.x86_64.rpm: Already downloaded
Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction check error:
  file /usr/lib64/libGLESv2.so.2.0.0 from install of mesa-libGLES-12.0.3-3.fc25.                           x86_64 conflicts with file from package libglvnd-gles-1:0.2.999-10.gitdc16f8c.fc                           25.x86_64

# sudo dnf downgrade libglvnd-glx --allowerasing
Last metadata expiration check: 0:12:01 ago on Wed Mar  8 14:59:42 2017.
Package libglvnd-glx of lowest version already installed, cannot downgrade it.
Error: Nothing to do.

Hoping a new package is pushed soon, although unsure if this will resolve my issue.  Is there another workaround I am able to use without removing hundreds of packages or enabling packages from updates-testing repo?

Comment 6 Pierre Ossman 2017-03-08 11:22:59 UTC
You probably need to downgrade all mesa packages. I.e.:

> $ sudo dnf downgrade 'mesa-*' --allowerasing

Comment 7 JM 2017-03-08 14:51:19 UTC
Btw. libepoxy in version 1.4.1 (https://github.com/anholt/libepoxy/releases) solves the problem as well. I usedd the SRPM 

libepoxy-1.3.1-4.fc26.src.rpm 

and replaced the version 1.3.1 with 1.4.1, changed the SPEC-File, recompiled the SRPM and installed the new 1.4.1 RPM on my systems and now I can use Mesa 13 without a "Segmentation fault" :-).

Comment 8 Bradi 2017-03-08 22:36:03 UTC
(In reply to Pierre Ossman from comment #6)
> You probably need to downgrade all mesa packages. I.e.:
> 
> > $ sudo dnf downgrade 'mesa-*' --allowerasing

Thanks Pierre, this resolves the problem for me.  Grateful for your assistance.  Hoping the update to mesa-* is not too far away so I can update again.

Comment 9 JM 2017-03-09 00:24:13 UTC
(In reply to Bradi from comment #8)

> Hoping the update to mesa-* is not too far away so I can update again.

The bug is inside "libepoxy", see Bug #1395366. Mesa 13 triggers only the bug in libepoxy.

Comment 10 Norman Gaywood 2017-03-09 00:41:14 UTC
Bradi,

You can edit /etc/dnf/dnf.conf and place these lines in there:

# https://bugzilla.redhat.com/show_bug.cgi?id=1427174
exclude=mesa-*

Then you can update without updating mesa. Remove the lines when the fix is in.

Comment 11 Norman Gaywood 2017-03-09 02:15:30 UTC
I just tried installing the latest libepoxy-1.4.1-1.fc25 from koji

https://koji.fedoraproject.org/koji/buildinfo?buildID=866615

Good news, XFCE4 desktop apps no longer segfault when running under x2go

xfce4-terminal works. xfce4-settings-manager works, which I think is new, it hasn't worked under x2go for some time.

emacs still does not work. Long standing bug #1349412

glxinfo has stopped working and now gives:
$ glxinfo
name of display: :50.0
Error: couldn't find RGB GLX visual or fbconfig

Previously, before mesa update, glxinfo printed:
$ glxinfo
name of display: :51.0
display: :51  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_visual_info, 
    GLX_EXT_visual_rating, GLX_OML_swap_method, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier, 
    GLX_SGI_make_current_read
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
[clip]

Comment 12 JM 2017-03-09 17:13:58 UTC
(In reply to Norman Gaywood from comment #11)

> emacs still does not work. Long standing bug #1349412

The comment #13 in bug #1349412 suggest to uncomment 

X2GO_NXAGENT_DEFAULT_OPTIONS+=" -extension GLX"

in

/etc/x2go/x2goagent.options

This solved the problem for me. emacs works now with x2go.

Comment 13 JM 2017-03-09 17:47:23 UTC
Hmm... even with 

X2GO_NXAGENT_DEFAULT_OPTIONS+=" -extension GLX"

I still have problems with emacs and x2go. emacs is a little bit more stable but still crashes... Btw. libepoxy is now version 1.4.1.

Comment 14 Norman Gaywood 2017-03-10 04:50:19 UTC
Indications from some other bugs suggest that the problem with glxinfo is in libglvnd

From: https://bugs.freedesktop.org/show_bug.cgi?id=99987#c9

> Seeing as Ubuntu 17.04 also will have Mesa 13, I installed their nightly build to test. My tests show that the problem does not exist on Ubuntu 17.04. Applications such as glxgears work fine in ThinLinc, and it does seem like OpenGL is properly available.
> Briefly looking at the differences between the Fedora installation and the Ubuntu one shows that GLVND isn't used in the latter. This would further indicate that the problem lies in GLVND?

There is a similar bug #1429894 with regard to xdriinfo also pointing to libglvnd.

https://bugzilla.redhat.com/show_bug.cgi?id=1429894

Summary:
glxinfo works under x2go with mesa 12.0.3-3.fc25
glxinfo does not work under x2go with mesa 13.0.4-1.fc25

mesa 13.0.4-1 introduced libglvnd

Segfault issues with xfce4 programs and others like gnome-terminal were fixed with an update to libepoxy-1.4.1-1.fc25

emacs seg faulted with old libepoxy in same place as xfce4 programs. But with updated libepoxy, segfault has moved to different place as per bug #1349412

Comment 15 JM 2017-03-10 12:58:09 UTC
glxinfo, etc. works with mesa 13.0.3-5 (https://koji.fedoraproject.org/koji/buildinfo?buildID=837227) without libglvnd, so it looks like that libglvnd is the problem.

Comment 16 RobbieTheK 2017-03-10 14:59:15 UTC
No matter what I try still getting the segfault on Fedora 25:

1)
kernel: mate-session[27468]: segfault at 0 ip 00007fae5a93a6a7 sp 00007ffed6bf9278 error 4 in libX11-xcb.so.1.0.0[7fae5a93a000+1000]
abrt-hook-ccpp: Process 27468 (mate-session) of user xxxx killed by SIGSEGV - dumping core

2) The standard Fedora repos don't have the koji libexpoxy update as I ran dnf clean all and dnf upgrade to get the latest:
rpm -q libepoxy
libepoxy-1.3.1-3.fc25.x86_64

3) I made sure we're still downgraded with mesa:
rpm -q mesa-libGL
mesa-libGL-12.0.3-3.fc25.x86_64
mesa-libGL-12.0.3-3.fc25.i686

4) I can confirm that glxinfo work with the above and fails with mesa-libGL-13.

5) There is a copr repo for the emacs X2Go crash: https://copr.fedorainfracloud.org/coprs/nbecker/emacs-x2go/

Comment 17 RobbieTheK 2017-03-11 18:03:45 UTC
Now getting this from def update:
Error: Transaction check error:
  file /usr/lib64/libEGL.so.1.0.0 from install of libglvnd-egl-1:0.2.999-10.gitdc16f8c.fc25.x86_64 conflicts with file from package mesa-libEGL-12.0.3-3.fc25.x86_64

Comment 18 Bradi 2017-03-12 23:57:06 UTC
Update to libepoxy.x86_64 1.4.1-1.fc25 looks to have resolved the issues I was having with mesa-*.x64_86 13.0.4-1.fc25.

Installing:
 <snip>
 libglvnd-egl                                                       x86_64                                        1:0.2.999-10.gitdc16f8c.fc25                                         updates                                          43 k
 libglvnd-gles                                                      x86_64                                        1:0.2.999-10.gitdc16f8c.fc25                                         updates                                          31 k
 libglvnd-glx                                                       x86_64                                        1:0.2.999-10.gitdc16f8c.fc25                                         updates                                         124 k
Upgrading:
 <snip>
 libepoxy                                                           x86_64                                        1.4.1-1.fc25                                                         updates                                         207 k
 mesa-dri-drivers                                                   x86_64                                        13.0.4-1.fc25                                                        updates                                          11 M
 mesa-filesystem                                                    x86_64                                        13.0.4-1.fc25                                                        updates                                          24 k
 mesa-libEGL                                                        x86_64                                        13.0.4-1.fc25                                                        updates                                         103 k
 mesa-libGL                                                         x86_64                                        13.0.4-1.fc25                                                        updates                                         165 k
 mesa-libGLES                                                       x86_64                                        13.0.4-1.fc25                                                        updates                                          22 k
 mesa-libgbm                                                        x86_64                                        13.0.4-1.fc25                                                        updates                                          42 k
 mesa-libglapi                                                      x86_64                                        13.0.4-1.fc25                                                        updates                                          50 k
 mesa-libwayland-egl                                                x86_64                                        13.0.4-1.fc25                                                        updates                                          25 k
 mesa-libxatracker                                                  x86_64                                        13.0.4-1.fc25                                                        updates                                         1.4 M
 xorg-x11-drv-wacom                                                 x86_64                                        0.34.2-1.fc25                                                        updates                                         312 k

Thanks to all involved.

Comment 19 Hans de Goede 2017-03-13 12:33:37 UTC
I cannot reproduce this I've tried both:

Xvnc :1 -rfbauth /home/hans/.vnc/passwd

And then started an xterm on DISPLAY=:1 and in that xterm run glxgears as well as glxinfo fine using lvmpipe.

As well as running "vncserver" and then starting a xterm + glxgears as well as glxinfo fine inside the session running there.

Please provide detailed reproduction instructions, specifically the commandline used to launch Xvnc causing this problem as shown by e.g.: "ps auxw | grep Xvnc"

Comment 20 JM 2017-03-13 12:46:21 UTC
With x2go I get this for glxinfo and glxgears

glxinfo
name of display: :50
Error: couldn't find RGB GLX visual or fbconfig

glxgears
Error: couldn't get an RGB, Double-buffered visual

I know it's not Xvnc but the problem is the same (see comment #2). libepoxy in version 1.4.1 fixed the segmentation faults but the problem with glxinfo and glxgears is still there.

Comment 21 Pierre Ossman 2017-03-13 12:47:39 UTC
Do you know which version of Xorg that x2go build is based on? And perhaps which Mesa it was compiled against? Where did you get the build?

Comment 22 Pierre Ossman 2017-03-13 13:06:22 UTC
If it's Fedora standard build, it seems like x2go bundles its own version of Mesa and Xorg. Both of them are ancient (Xorg is 6.9.0).

Comment 23 Hans de Goede 2017-03-13 13:38:15 UTC
(In reply to Pierre Ossman from comment #22)
> If it's Fedora standard build, it seems like x2go bundles its own version of
> Mesa and Xorg. Both of them are ancient (Xorg is 6.9.0).

Right, look at: http://wiki.x2go.org/doku.php/doc:de-compat

Which says:

" As of version 3.5.0.x, nxagent is forked from the X.org 6.9 codebase (from 2005.) Therefore, there are 4 reasons why certain modern “3d-ish” desktops are incompatible with nxagent, and therefore X2Go.

#1    The desktop environment requires the X11 extension “Xcomposite”, which nxagent 3.5.0.x and X.org 6.9 do not support.
#2    The desktop environment requires a newer version of the X11 extension “GLX” (OpenGL) than nxagent 3.5.0.x and X.org 6.9 provide (version 1.2).
#3    The desktop environment requires a newer version of the X11 extension “XRANDR” than nxagent 3.5.0.x provides (version 1.2).
#4    The desktop environment checks for a specific physical graphics driver, but nxagent doesn't use physical graphics adapters/drivers.

Ultimately, addressing issues #1 and #2 requires a lot of work."

I believe that #2 is the problem here, when running nxagent as xserver the xserver is presenting libGLX with a glx version of 1.2, where as 1.4 is current now a days. It seems that the libglvnd provided libGLX cannot work with such and old glx server extension ? I will contact libglvnd upstream about this.

So it looks like x2go will need to get fixed to provide a newer glx extension to X-clients running under it, upstream has some docs on this here: http://wiki.x2go.org/doku.php/wiki:development:new-feature-brainstorming#nx-libs . Specifically it seems that a nxagent rewrite is under progress here: https://arctica-project.org/landing/start .

I do apologize for breaking this halfway through F25's lifetime.

A workaround for this is to downgrade to: mesa-13.0.3-5.fc25 and then version-freeze mesa by adding:

exclude=mesa*

To /etc/dnf/dnf.conf .

Comment 24 Hans de Goede 2017-03-13 13:41:15 UTC
Can someone please provide *detailed* reproduction instructions for how to reproduce this using Fedora 25's x2go packages?

I've tried installing x2goserver + x2goserver-xsession + x2goclient and then running x2goclient and selecting either GNOME or terminal as session type there, but all I get is a connection being build then 1-2 minutes of nothing and then the connection getting closed again.

Comment 25 Pierre Ossman 2017-03-13 13:43:07 UTC
(In reply to Hans de Goede from comment #23)
> 
> I believe that #2 is the problem here, when running nxagent as xserver the
> xserver is presenting libGLX with a glx version of 1.2, where as 1.4 is
> current now a days. It seems that the libglvnd provided libGLX cannot work
> with such and old glx server extension ? I will contact libglvnd upstream
> about this.
> 

Very interesting. Do you know what that means in regard to Xorg versions? TigerVNC has been using 1.14 and 1.15 in most builds, as has ThinLinc.

Comment 26 JM 2017-03-13 13:50:18 UTC
(In reply to Hans de Goede from comment #24)
> Can someone please provide *detailed* reproduction instructions for how to
> reproduce this using Fedora 25's x2go packages?
> 
> I've tried installing x2goserver + x2goserver-xsession + x2goclient and then
> running x2goclient and selecting either GNOME or terminal as session type
> there, but all I get is a connection being build then 1-2 minutes of nothing
> and then the connection getting closed again.

Use XFCE as session type (and of course install it on the host :-)). For me only XFCE works as session type, GNOME, etc. fails.

Comment 27 Pierre Ossman 2017-03-13 13:57:32 UTC
(In reply to Pierre Ossman from comment #25)
> 
> Very interesting. Do you know what that means in regard to Xorg versions?
> TigerVNC has been using 1.14 and 1.15 in most builds, as has ThinLinc.

I had a look myself and 1.8 was the first version with GLX 1.4. Hence that's not the reason for the failures as Xorg 1.14 fails.

Comment 28 JM 2017-03-13 13:59:30 UTC
(In reply to Hans de Goede from comment #23)

> I believe that #2 is the problem here, when running nxagent as xserver the
> xserver is presenting libGLX with a glx version of 1.2, where as 1.4 is
> current now a days. It seems that the libglvnd provided libGLX cannot work
> with such and old glx server extension ? I will contact libglvnd upstream
> about this.
> 
> So it looks like x2go will need to get fixed to provide a newer glx
> extension to X-clients running under it, upstream has some docs on this
> here:
> http://wiki.x2go.org/doku.php/wiki:development:new-feature-brainstorming#nx-
> libs . Specifically it seems that a nxagent rewrite is under progress here:
> https://arctica-project.org/landing/start .
> 
> I do apologize for breaking this halfway through F25's lifetime.
> 
> A workaround for this is to downgrade to: mesa-13.0.3-5.fc25 and then
> version-freeze mesa by adding:
> 
> exclude=mesa*
> 
> To /etc/dnf/dnf.conf .

Thank you for looking into this. I already thought that x2go is the real problem here. x2go is using old components but I have no real alternatives for x2go (for multi user connections). For now I version-freeze Mesa and see if I - in the long run - can somehow replace x2go

Comment 29 JM 2017-03-13 14:00:35 UTC
(In reply to Pierre Ossman from comment #22)
> If it's Fedora standard build, it seems like x2go bundles its own version of
> Mesa and Xorg. Both of them are ancient (Xorg is 6.9.0).

Yep, it's the Fedora standard build.

Comment 30 Orion Poplawski 2017-03-13 14:57:51 UTC
*** Bug 1399357 has been marked as a duplicate of this bug. ***

Comment 31 Hans de Goede 2017-03-13 21:28:49 UTC
Reaction from upstream libglvnd maintainer:

"Do you have a symlink for libGLX_indirect.so.0 that points to Mesa?

Libglvnd relies on a GLX extension to tell it which vendor library to use, and if the server doesn't support that extension (which I'm assuming it doesn't), then it'll try to load a vendor library named libGLX_indirect.so.0 instead. The reason for that is so that indirect rendering can still work when you connect to a remote X server.

libGLX_indirect.so.0 should just be a symlink to another vendor. For indirect rendering, any vendor will do, since they should all speak the same GLX protocol.

But, if libGLX_indirect.so.0 doesn't exist, then libglvnd won't be able to find any vendor library to load, so it won't be able to handle any GLX calls at all.

Alternately, you can just override libglvnd's vendor library selection by setting an environment variable, like this:
__GLX_VENDOR_LIBRARY_NAME=mesa"

Can someone try running:

"__GLX_VENDOR_LIBRARY_NAME=mesa glxinfo"

and:

"__GLX_VENDOR_LIBRARY_NAME=mesa glxgears"

From a terminal in x2go ?

Also on the server try doing:

sudo ln -s /usr/lib64/libGLX_mesa.so.0 /usr/lib64/libGLX_indirect.so.0

And see if that fixes things without needing to use __GLX_VENDOR_LIBRARY_NAME=mesa ?

Comment 32 Norman Gaywood 2017-03-13 22:53:51 UTC
Looks good! Versions listed below. 
This is using x2goclient to connect to an x2goserver with an XFCE desktop
Inside the xfce4-terminal:

$ glxinfo
name of display: :50.0
Error: couldn't find RGB GLX visual or fbconfig

$ __GLX_VENDOR_LIBRARY_NAME=mesa glxinfo
name of display: :50.0
display: :50  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_visual_info,
    GLX_EXT_visual_rating, GLX_OML_swap_method, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
    GLX_SGI_make_current_read
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
[snip]
$ __GLX_VENDOR_LIBRARY_NAME=mesa glxgears
4089 frames in 5.0 seconds = 817.788 FPS
[snip glxgears works]

$ sudo ln -s /usr/lib64/libGLX_mesa.so.0 /usr/lib64/libGLX_indirect.so.0
$ glxinfo
name of display: :50.0
display: :50  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
[snip]
$ glxgears
4901 frames in 5.0 seconds = 980.084 FPS
[snip glxgears works]

Installed on the server:
x2goserver-fmbindings-4.0.1.20-1.fc25.x86_64
x2goserver-4.0.1.20-1.fc25.x86_64
x2goserver-xsession-4.0.1.20-1.fc25.x86_64
x2goagent-3.5.0.32-4.fc24.x86_64
cups-x2go-3.0.1.3-2.fc24.noarch
x2godesktopsharing-3.1.1.3-1.fc25.x86_64
x2goserver-printing-4.0.1.20-1.fc25.x86_64
mesa-libglapi-13.0.4-1.fc25.i686
mesa-libGL-devel-13.0.4-1.fc25.x86_64
mesa-libGL-13.0.4-1.fc25.x86_64
mesa-libgbm-13.0.4-1.fc25.x86_64
mesa-libOSMesa-13.0.4-1.fc25.x86_64
mesa-libwayland-egl-13.0.4-1.fc25.x86_64
mesa-libwayland-egl-devel-13.0.4-1.fc25.x86_64
mesa-libEGL-13.0.4-1.fc25.x86_64
mesa-libxatracker-13.0.4-1.fc25.x86_64
mesa-libGLES-13.0.4-1.fc25.x86_64
mesa-libGLU-devel-9.0.0-10.fc24.x86_64
mesa-filesystem-13.0.4-1.fc25.x86_64
mesa-libgbm-devel-13.0.4-1.fc25.x86_64
mesa-libEGL-devel-13.0.4-1.fc25.i686
mesa-libglapi-13.0.4-1.fc25.x86_64
mesa-libgbm-13.0.4-1.fc25.i686
mesa-libGLU-9.0.0-10.fc24.x86_64
mesa-libGL-13.0.4-1.fc25.i686
mesa-libEGL-13.0.4-1.fc25.i686
mesa-libEGL-devel-13.0.4-1.fc25.x86_64
mesa-dri-drivers-13.0.4-1.fc25.x86_64
libglvnd-0.2.999-10.gitdc16f8c.fc25.x86_64
libglvnd-0.2.999-10.gitdc16f8c.fc25.i686
libepoxy-1.4.1-1.fc25.x86_64

Comment 33 JM 2017-03-13 23:08:28 UTC
Btw. 

dnf provides /usr/lib64/libGLX_indirect.so.0

shows

xorg-x11-drv-nvidia-libs-1:375.26-11.fc25.x86_64 : Libraries for xorg-x11-drv-nvidia
Repo        : rpmfusion-nonfree-updates

So I installed a x2go server on a system with NVIDIA-Drivers and there I don't need any modifications (no __GLX_VENDOR_LIBRARY_NAME=mesa) for glxinfo or glxgears, it just works... I guess because /usr/lib64/libGLX_indirect.so.0 exists? 

lrwxrwxrwx. 1 root root 23 23. Jan 16:10 /usr/lib64/libGLX_indirect.so.0 -> libGLX_nvidia.so.375.26

Comment 34 JM 2017-03-13 23:29:03 UTC
ln -s /usr/lib64/libGLX_mesa.so.0 /usr/lib64/libGLX_indirect.so.0 

solves the problem with glxinfo and glxgears, 

libepoxy 1.4.1 the problem with the segmentation fault so what's left is the problem with emacs and x2go :-) (Bug #1349412) but I guess Bug #1349412 is not related to Mesa 13 or libglvnd because Fedora 24 has the same problem.

Comment 35 Hans de Goede 2017-03-14 08:07:59 UTC
Good to hear that "ln -s /usr/lib64/libGLX_mesa.so.0 /usr/lib64/libGLX_indirect.so.0" fixes this. I will prepare an update to add this to the Fedora mesa pkgs, but I need to coordinate this with the rpmfusion packages, since those currently add such a symlink to the nvidia packages.

Comment 36 RobbieTheK 2017-03-17 14:03:20 UTC
Going from Windows 10 X2Go to Fedora 25 using MATE seems to work however with XFCE it just hangs and here's my .xfce log file:
cat .xfce4-session.verbose-log
log file opened
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "blueman-applet"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "abrt-applet"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "xfce4-power-manager"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "nm-applet"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:649] xfsm_startup_autostart_xdg(): only show in XFCE set, launching
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "/usr/libexec/tracker-miner-apps"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:649] xfsm_startup_autostart_xdg(): only show in XFCE set, launching
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "/usr/libexec/tracker-miner-user-guides"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:649] xfsm_startup_autostart_xdg(): only show in XFCE set, launching
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "xfsettingsd"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:649] xfsm_startup_autostart_xdg(): only show in XFCE set, launching
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "/usr/libexec/evolution/evolution-alarm-notify"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "/usr/bin/vmware-user-suid-wrapper"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:649] xfsm_startup_autostart_xdg(): only show in XFCE set, launching
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "/usr/libexec/tracker-extract"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:649] xfsm_startup_autostart_xdg(): only show in XFCE set, launching
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "/usr/libexec/xfce-polkit"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:649] xfsm_startup_autostart_xdg(): only show in XFCE set, launching
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "xscreensaver -no-splash"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "start-pulseaudio-x11"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:681] xfsm_startup_autostart_xdg(): start_at_spi (a11y support), skipping
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "/usr/bin/seapplet"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "/usr/bin/spice-vdagent"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "/usr/libexec/liveinst-setup.sh"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "xdg-user-dirs-update"
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:629] xfsm_startup_autostart_xdg(): hidden set
TRACE[xfsm-startup.c:712] xfsm_startup_autostart_xdg(): Autostart: running command "imsettings-switch -n -q -x"
TRACE[xfsm-manager.c:823] xfsm_manager_signal_startup_done(): Manager finished startup, entering IDLE mode now

TRACE[xfsm-manager.c:303] xfsm_manager_set_state():
state is now XFSM_MANAGER_IDLE
TRACE[sm-layer.c:162] sm_new_client(): ICE connection fd = 12, received NEW CLIENT

TRACE[sm-layer.c:213] sm_register_client(): ICE connection fd = 12, received REGISTER CLIENT [Previous Id = None]

TRACE[sm-layer.c:162] sm_new_client(): ICE connection fd = 13, received NEW CLIENT

TRACE[sm-layer.c:213] sm_register_client(): ICE connection fd = 13, received REGISTER CLIENT [Previous Id = None]

TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (Program, xfsettingsd)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (UserID, myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (RestartStyleHint, 2)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (ProcessID, 32473)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (CurrentDirectory, /u/ourserver/myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (_GSM_Priority, 25)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (_GSM_DesktopFile, /etc/xdg/autostart/xfsettingsd.desktop)
TRACE[sm-layer.c:162] sm_new_client(): ICE connection fd = 14, received NEW CLIENT

TRACE[sm-layer.c:213] sm_register_client(): ICE connection fd = 14, received REGISTER CLIENT [Previous Id = None]

TRACE[sm-layer.c:162] sm_new_client(): ICE connection fd = 15, received NEW CLIENT

TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (Program, xfce4-panel)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (UserID, myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (RestartStyleHint, 2)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (ProcessID, 32468)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (CurrentDirectory, /u/ourserver/myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (_GSM_Priority, 25)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (Program, xfdesktop)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (UserID, myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (RestartStyleHint, 2)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (ProcessID, 32472)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (CurrentDirectory, /u/ourserver/myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (_GSM_Priority, 35)
TRACE[sm-layer.c:213] sm_register_client(): ICE connection fd = 15, received REGISTER CLIENT [Previous Id = None]

TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (Program, xfce4-power-manager)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (UserID, myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (RestartStyleHint, 0)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (ProcessID, 32506)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (CurrentDirectory, /)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (_GSM_Priority, 50)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (_GSM_DesktopFile, /etc/xdg/autostart/xfce4-power-manager.desktop)
TRACE[xfsm-properties.c:629] xfsm_properties_set_from_smprop(): -> Set strv (RestartCommand)
TRACE[xfsm-properties.c:629] xfsm_properties_set_from_smprop(): -> Set strv (CloneCommand)
TRACE[sm-layer.c:304] sm_save_yourself_done(): Client Id = 219308c1c-d6ec-4027-a938-1a35b2b8a768, received SAVE YOURSELF DONE [Success = True]

TRACE[xfsm-manager.c:1295] xfsm_manager_save_yourself_done(): enteringTRACE[xfsm-properties.c:629] xfsm_properties_set_from_smprop(): -> Set strv (RestartCommand)
TRACE[xfsm-properties.c:629] xfsm_properties_set_from_smprop(): -> Set strv (CloneCommand)
TRACE[sm-layer.c:304] sm_save_yourself_done(): Client Id = 25f978875-2cd3-4974-add4-019a8b875435, received SAVE YOURSELF DONE [Success = True]

TRACE[xfsm-manager.c:1295] xfsm_manager_save_yourself_done(): enteringTRACE[ice-layer.c:99] ice_error_handler(): ICE connection fd = 14, ICE I/O error on connection
TRACE[xfsm-properties.c:629] xfsm_properties_set_from_smprop(): -> Set strv (RestartCommand)
TRACE[xfsm-properties.c:629] xfsm_properties_set_from_smprop(): -> Set strv (CloneCommand)
TRACE[sm-layer.c:304] sm_save_yourself_done(): Client Id = 2c64a9516-a0dd-45dd-88ea-a3cb1c82ff56, received SAVE YOURSELF DONE [Success = True]

TRACE[xfsm-manager.c:1295] xfsm_manager_save_yourself_done(): enteringTRACE[ice-layer.c:99] ice_error_handler(): ICE connection fd = 12, ICE I/O error on connection
TRACE[xfsm-manager.c:404] xfsm_manager_handle_failed_properties(): Client Id = 25f978875-2cd3-4974-add4-019a8b875435 disconnected, restarting
TRACE[sm-layer.c:162] sm_new_client(): ICE connection fd = 12, received NEW CLIENT

TRACE[sm-layer.c:213] sm_register_client(): ICE connection fd = 12, received REGISTER CLIENT [Previous Id = 25f978875-2cd3-4974-add4-019a8b875435]

TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (Program, xfce4-panel)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (UserID, myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (RestartStyleHint, 2)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (ProcessID, 554)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (CurrentDirectory, /u/ourserver/myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (_GSM_Priority, 25)
TRACE[ice-layer.c:99] ice_error_handler(): ICE connection fd = 12, ICE I/O error on connection
TRACE[xfsm-manager.c:404] xfsm_manager_handle_failed_properties(): Client Id = 25f978875-2cd3-4974-add4-019a8b875435 disconnected, restarting
TRACE[sm-layer.c:162] sm_new_client(): ICE connection fd = 12, received NEW CLIENT

TRACE[sm-layer.c:213] sm_register_client(): ICE connection fd = 12, received REGISTER CLIENT [Previous Id = 25f978875-2cd3-4974-add4-019a8b875435]

TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (Program, xfce4-panel)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (UserID, myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (RestartStyleHint, 2)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (ProcessID, 598)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (CurrentDirectory, /u/ourserver/myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (_GSM_Priority, 25)
TRACE[ice-layer.c:99] ice_error_handler(): ICE connection fd = 12, ICE I/O error on connection
TRACE[xfsm-manager.c:404] xfsm_manager_handle_failed_properties(): Client Id = 25f978875-2cd3-4974-add4-019a8b875435 disconnected, restarting
TRACE[sm-layer.c:162] sm_new_client(): ICE connection fd = 12, received NEW CLIENT

TRACE[sm-layer.c:213] sm_register_client(): ICE connection fd = 12, received REGISTER CLIENT [Previous Id = 25f978875-2cd3-4974-add4-019a8b875435]

TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (Program, xfce4-panel)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (UserID, myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (RestartStyleHint, 2)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (ProcessID, 642)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (CurrentDirectory, /u/ourserver/myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (_GSM_Priority, 25)
TRACE[ice-layer.c:99] ice_error_handler(): ICE connection fd = 12, ICE I/O error on connection
TRACE[xfsm-manager.c:404] xfsm_manager_handle_failed_properties(): Client Id = 25f978875-2cd3-4974-add4-019a8b875435 disconnected, restarting
TRACE[sm-layer.c:162] sm_new_client(): ICE connection fd = 12, received NEW CLIENT
TRACE[sm-layer.c:213] sm_register_client(): ICE connection fd = 12, received REGISTER CLIENT [Previous Id = 25f978875-2cd3-4974-add4-019a8b875435]
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (Program, xfce4-panel)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (UserID, myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (RestartStyleHint, 2)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (ProcessID, 714)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (CurrentDirectory, /u/ourserver/myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (_GSM_Priority, 25)
TRACE[ice-layer.c:99] ice_error_handler(): ICE connection fd = 12, ICE I/O error on connection
TRACE[xfsm-manager.c:404] xfsm_manager_handle_failed_properties(): Client Id = 25f978875-2cd3-4974-add4-019a8b875435 disconnected, restarting
TRACE[sm-layer.c:162] sm_new_client(): ICE connection fd = 12, received NEW CLIENT
TRACE[sm-layer.c:213] sm_register_client(): ICE connection fd = 12, received REGISTER CLIENT [Previous Id = 25f978875-2cd3-4974-add4-019a8b875435]
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (Program, xfce4-panel)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (UserID, myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (RestartStyleHint, 2)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (ProcessID, 758)
TRACE[xfsm-properties.c:489] xfsm_properties_set_string(): -> Set string (CurrentDirectory, /u/ourserver/myuser)
TRACE[xfsm-properties.c:555] xfsm_properties_set_uchar(): -> Set uchar (_GSM_Priority, 25)
TRACE[ice-layer.c:99] ice_error_handler(): ICE connection fd = 12, ICE I/O error on connection
TRACE[xfsm-manager.c:397] xfsm_manager_handle_failed_properties(): Client Id = 25f978875-2cd3-4974-add4-019a8b875435, reached maximum attempts [Restart attempts = 6]
   Will be re-scheduled for run on next startup
TRACE[ice-layer.c:99] ice_error_handler(): ICE connection fd = 15, ICE I/O error on connection
TRACE[xfsm-manager.c:428] xfsm_manager_handle_failed_properties(): Client Id 2c64a9516-a0dd-45dd-88ea-a3cb1c82ff56 exited, removing from session.

Comment 37 Hans de Goede 2017-03-20 09:19:20 UTC
There are a lot of different issues being discussed in this bug. I intend to use this bug only to track glxinfo / glxgears not working with indirect rendering (such as under x2go) for any other issues please use either an existing x2go bug or file a new bug against x2go.

The rpmfusion xorg-x11-drv-nvidia pkgs have been updated so that they will no longer conflict with a fixed mesa offering the needed libGLX_indirect.so.0 symlink. I'm preparing fixed package builds for F25+ now.

Comment 38 Fedora Update System 2017-03-20 15:06:54 UTC
mesa-17.0.1-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-20709e6c23

Comment 39 Fedora Update System 2017-03-20 15:07:25 UTC
mesa-13.0.4-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a85ea344c6

Comment 40 Fedora Update System 2017-03-20 18:50:00 UTC
mesa-17.0.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-741d36d0b1

Comment 41 Fedora Update System 2017-03-21 05:21:23 UTC
mesa-13.0.4-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a85ea344c6

Comment 42 Fedora Update System 2017-03-21 14:25:35 UTC
mesa-17.0.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-741d36d0b1

Comment 43 Fedora Update System 2017-03-24 18:55:34 UTC
mesa-13.0.4-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 44 Fedora Update System 2017-04-01 17:18:08 UTC
mesa-17.0.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.