Bug 142732 - Cannot edit any calendar views
Cannot edit any calendar views
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-13 09:56 EST by Dennis Gregorovic
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-08 17:22:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gregorovic 2004-12-13 09:56:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041203 Firefox/1.0

Description of problem:
In calendar mode, select 'View / Current View / Define Views...'.  Then, select a view and click 'Edit...'.  Another dialog should come up that allows you to edit the view.  Instead, nothing happens.

Version-Release number of selected component (if applicable):
evolution-2.0.2-8

How reproducible:
Always

Steps to Reproduce:
see description

Additional info:
Comment 1 Dave Malcolm 2004-12-16 12:04:05 EST
Looks like only Table views can be edited, the various other types
can't be edited.

So it looks like the Edit button should be made insensitive for these
types.
Comment 2 Dave Malcolm 2004-12-16 13:42:38 EST
The dialog in question is in the libgal2 package:
gal/menus/gal-define-views-dialog.c

I tried a patch, but it looks like we need to add a new vtable entry
for GalViewClass: "is_editable" and patch libgal2 and evolution
accordingly; an ABI change.
Comment 3 Dave Malcolm 2005-12-08 17:22:54 EST
(fixed in evolution-2.5.2-1, probably earlier)

* This problem will be resolved in a future major release of Red Hat Enterprise
Linux. Red Hat does not currently plan to provide a resolution for this in a Red
Hat Enterprise Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects. 


Note You need to log in before you can comment on or make changes to this bug.