Bug 1427398 - irda: ioctl(SIOCSIFFLAGS): Resource temporarily unavailable
irda: ioctl(SIOCSIFFLAGS): Resource temporarily unavailable
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
25
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-28 00:56 EST by Jeremie R.
Modified: 2017-08-31 05:41 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-31 05:41:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremie R. 2017-02-28 00:56:53 EST
Description of problem:

The Irda usb stick doesn't work since kernel-4.9.x. (Fedora 24 or 25)

Version-Release number of selected component (if applicable):

Kernel: kernel-4.9.11-200.fc25.x86_64
Irda-utils: irda-utils-0.9.18.fc25


How reproducible:


Steps to Reproduce:
1. Plug an irda usb stick.
2. run: sudo irattach irda0 -s

Actual results:
The irda's led doesn't blink.

Expected results:
The irda's led blinks.


Additional info:

Tested on two different computer.
First on Fedora 24 with a kernel-4.5.5
Work like a charm, even with the modprobe error.
To have the right running status, I must downgrade the kernel to a 4.5.5.

févr. 27 21:30:39 laptop.rapin sudo[2677]:    rapin : TTY=pts/0 ; PWD=/home/rapin ; USER=root ; COMMAND=/sbin/irattach irda0 -s
févr. 27 21:30:39 laptop.rapin audit[2677]: USER_CMD pid=2677 uid=1000 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='cwd="/home/rapin" cmd=6972617474616368206972646
févr. 27 21:30:39 laptop.rapin audit[2677]: CRED_REFR pid=2677 uid=0 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:setcred grantors=pam_unix acct="root" exe=
févr. 27 21:30:39 laptop.rapin sudo[2677]: pam_systemd(sudo:session): Cannot create session: Already running in a session
févr. 27 21:30:39 laptop.rapin audit[2677]: USER_START pid=2677 uid=0 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:session_open grantors=pam_keyinit,pam_lim
févr. 27 21:30:39 laptop.rapin sudo[2677]: pam_unix(sudo:session): session opened for user root by rapin(uid=0)
févr. 27 21:30:39 laptop.rapin irattach[2681]: executing: '/sbin/modprobe irda0'
févr. 27 21:30:39 laptop.rapin irattach[2681]: + modprobe: FATAL: Module irda0 not found in directory /lib/modules/4.5.5-300.fc24.x86_64
févr. 27 21:30:39 laptop.rapin irattach[2681]: Trying to load module irda0 exited with status 1
févr. 27 21:30:39 laptop.rapin sudo[2677]: pam_unix(sudo:session): session closed for user root
févr. 27 21:30:39 laptop.rapin audit[2677]: USER_END pid=2677 uid=0 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:session_close grantors=pam_keyinit,pam_limi
févr. 27 21:30:39 laptop.rapin audit[2677]: CRED_DISP pid=2677 uid=0 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:setcred grantors=pam_unix acct="root" exe=
févr. 27 21:30:39 laptop.rapin irattach[2685]: executing: 'echo laptop > /proc/sys/net/irda/devname'
févr. 27 21:30:39 laptop.rapin irattach[2685]: executing: 'echo 1 > /proc/sys/net/irda/discovery'
févr. 27 21:30:39 laptop.rapin irattach[2685]: Starting device irda0


Second on a fedora 25 with kernel-4.9.11-200.fc25.x86_64

Feb 27 20:13:27 laptop-freetibet sudo[19099]:  jeremie : TTY=pts/0 ; PWD=/home/jeremie ; USER=root ; COMMAND=/sbin/irattach irda0 -s
Feb 27 20:13:27 laptop-freetibet audit[19099]: USER_CMD pid=19099 uid=1000 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='cwd="/home/jeremie" cmd=6972617474616368206972646130202D73 terminal=pts/0 res=succe
Feb 27 20:13:27 laptop-freetibet audit[19099]: CRED_REFR pid=19099 uid=0 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:setcred grantors=pam_env,pam_unix acct="root" exe="/usr/bin/sudo" hostname=? a
Feb 27 20:13:27 laptop-freetibet audit[19099]: USER_START pid=19099 uid=0 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:session_open grantors=pam_keyinit,pam_limits,pam_keyinit,pam_limits,pam_syste
Feb 27 20:13:27 laptop-freetibet sudo[19099]: pam_systemd(sudo:session): Cannot create session: Already running in a session
Feb 27 20:13:27 laptop-freetibet sudo[19099]: pam_unix(sudo:session): session opened for user root by (uid=0)
Feb 27 20:13:27 laptop-freetibet irattach[19100]: executing: '/sbin/modprobe irda0'
Feb 27 20:13:27 laptop-freetibet irattach[19100]: + modprobe: FATAL: Module irda0 not found in directory /lib/modules/4.9.11-200.fc25.x86_64
Feb 27 20:13:27 laptop-freetibet irattach[19100]: Trying to load module irda0 exited with status 1
Feb 27 20:13:27 laptop-freetibet audit[19099]: USER_END pid=19099 uid=0 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:session_close grantors=pam_keyinit,pam_limits,pam_keyinit,pam_limits,pam_system
Feb 27 20:13:27 laptop-freetibet audit[19099]: CRED_DISP pid=19099 uid=0 auid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 msg='op=PAM:setcred grantors=pam_env,pam_unix acct="root" exe="/usr/bin/sudo" hostname=? a
Feb 27 20:13:27 laptop-freetibet sudo[19099]: pam_unix(sudo:session): session closed for user root
Feb 27 20:13:27 laptop-freetibet irattach[19104]: executing: 'echo laptop-freetibet > /proc/sys/net/irda/devname'
Feb 27 20:13:27 laptop-freetibet irattach[19104]: executing: 'echo 1 > /proc/sys/net/irda/discovery'
Feb 27 20:13:27 laptop-freetibet irattach[19104]: Starting device irda0
Feb 27 20:13:27 laptop-freetibet irattach[19104]: ioctl(SIOCSIFFLAGS): Resource temporarily unavailable
Feb 27 20:13:27 laptop-freetibet irattach[19104]: Stopping device irda0
Feb 27 20:13:27 laptop-freetibet irattach[19104]: exiting ...
Feb 27 20:13:27 laptop-freetibet kernel: Basic transceiver setup error

More information here: #1421387

Thanks for the help.

Jérémie R.
Comment 1 Justin M. Forbes 2017-04-11 10:50:23 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.
Comment 2 Jeremie R. 2017-04-25 12:57:23 EDT
More traces with kernel: 4.10.10-200.fc25.x86_64

[33907.771554] ------------[ cut here ]------------
[33907.771559] WARNING: CPU: 6 PID: 8355 at drivers/usb/core/hcd.c:1587 usb_hcd_map_urb_for_dma+0x49f/0x770
[33907.771560] transfer buffer not dma capable
[33907.771561] Modules linked in: mcs7780 irda ccm md4 nls_utf8 cifs dns_resolver fscache rfcomm fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_security iptable_mangle iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack libcrc32c iptable_raw iptable_security ebtable_filter ebtables cmac ip6table_filter ip6_tables bnep arc4 mei_wdt iTCO_wdt iTCO_vendor_support dell_wmi sparse_keymap ppdev intel_rapl iwlmvm x86_pkg_temp_thermal intel_powerclamp coretemp mac80211 uvcvideo dell_laptop kvm_intel dell_smm_hwmon
[33907.771607]  snd_hda_codec_hdmi videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core kvm dell_led dell_smbios dcdbas videodev snd_hda_codec_realtek snd_hda_codec_generic media btusb irqbypass btrtl intel_cstate iwlwifi intel_uncore snd_hda_intel intel_rapl_perf snd_hda_codec cfg80211 snd_hda_core snd_hwdep snd_seq snd_seq_device rtsx_pci_ms memstick joydev snd_pcm processor_thermal_device snd_timer mei_me snd mei hci_uart shpchp soundcore i2c_i801 intel_pch_thermal intel_soc_dts_iosf wmi btbcm btqca btintel bluetooth parport_pc parport dell_smo8800 pinctrl_sunrisepoint pinctrl_intel intel_lpss_acpi intel_lpss int3403_thermal int3400_thermal int340x_thermal_zone acpi_thermal_rel dell_rbtn rfkill acpi_pad acpi_als tpm_tis tpm_tis_core kfifo_buf tpm industrialio nfsd auth_rpcgss nfs_acl
[33907.771653]  lockd grace sunrpc vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) dm_crypt i915 rtsx_pci_sdmmc mmc_core crct10dif_pclmul crc32_pclmul crc32c_intel i2c_algo_bit ghash_clmulni_intel e1000e drm_kms_helper drm serio_raw ptp pps_core rtsx_pci video i2c_hid fjes i2c_dev
[33907.771676] CPU: 6 PID: 8355 Comm: irattach Tainted: G        W  OE   4.10.10-200.fc25.x86_64+debug #1
[33907.771677] Hardware name: Dell Inc. Latitude E5470/06DNG5, BIOS 1.11.4 12/22/2016
[33907.771678] Call Trace:
[33907.771681]  dump_stack+0x86/0xc3
[33907.771684]  __warn+0xcb/0xf0
[33907.771686]  warn_slowpath_fmt+0x5f/0x80
[33907.771689]  ? debug_dma_mapping_error+0x7b/0x90
[33907.771691]  usb_hcd_map_urb_for_dma+0x49f/0x770
[33907.771693]  usb_hcd_submit_urb+0x364/0xbb0
[33907.771696]  ? trace_hardirqs_on+0xd/0x10
[33907.771698]  ? mark_held_locks+0x76/0xa0
[33907.771700]  ? __raw_spin_lock_init+0x21/0x60
[33907.771702]  ? trace_hardirqs_on_caller+0xf5/0x1b0
[33907.771704]  usb_submit_urb+0x2f6/0x570
[33907.771706]  ? lockdep_init_map+0x61/0x210
[33907.771708]  usb_start_wait_urb+0x74/0x180
[33907.771710]  usb_control_msg+0xdc/0x120
[33907.771714]  mcs_get_reg+0x46/0x50 [mcs7780]
[33907.771716]  mcs_net_open+0xb5/0x5c0 [mcs7780]
[33907.771718]  ? raw_notifier_call_chain+0x16/0x20
[33907.771720]  __dev_open+0xc6/0x140
[33907.771722]  __dev_change_flags+0x9d/0x160
[33907.771724]  dev_change_flags+0x29/0x60
[33907.771726]  dev_ifsioc+0x1eb/0x3e0
[33907.771728]  dev_ioctl+0xf9/0x700
[33907.771731]  sock_do_ioctl+0x42/0x50
[33907.771733]  sock_ioctl+0x232/0x300
[33907.771735]  ? selinux_file_ioctl+0x125/0x1e0
[33907.771738]  do_vfs_ioctl+0xa3/0x740
[33907.771739]  ? up_read+0x1f/0x40
[33907.771742]  SyS_ioctl+0x79/0x90
[33907.771745]  entry_SYSCALL_64_fastpath+0x1f/0xc2
[33907.771746] RIP: 0033:0x7fe5b6c78787
[33907.771747] RSP: 002b:00007ffeb3e161b8 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
[33907.771749] RAX: ffffffffffffffda RBX: 0000000000000041 RCX: 00007fe5b6c78787
[33907.771750] RDX: 00007ffeb3e161c0 RSI: 0000000000008914 RDI: 0000000000000001
[33907.771751] RBP: 0000000000000001 R08: 000000000000000a R09: 0000000000000000
[33907.771752] R10: 0000000000004000 R11: 0000000000000246 R12: 00007ffeb3e165a8
[33907.771753] R13: 0000000000000000 R14: 000056171382deb8 R15: ffffffffffffffff
[33907.771755] ---[ end trace a227f9c684bbc14b ]---
Comment 3 Thomas Jarosch 2017-07-22 11:34:20 EDT
Upstream bug report:
https://bugzilla.kernel.org/show_bug.cgi?id=195217

I've posted a patch to fix the issue. It was also sent to netdev.
It's not too unlikely that it will land upstream and in -stable.
Comment 4 Thomas Jarosch 2017-08-29 16:12:30 EDT
The fix went upstream and is also part of -stable, f.e. in 4.12.6.

Confirmed the fix is working on Fedora 25 with the 4.12.8 kernel update.

-> this bugzilla entry is resolved.
Comment 5 Jeremie R. 2017-08-31 05:41:05 EDT
Hi, 

the fix works on Fedora25 and Fedora26 with kernel 4.12.8.

Thanks for you work. Great job.

Note You need to log in before you can comment on or make changes to this bug.