Bug 1427445 - sosreport 3.3 says: sosreport (version 3.2)
Summary: sosreport 3.3 says: sosreport (version 3.2)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sos
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro Bonazzola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-28 09:04 UTC by Yedidyah Bar David
Modified: 2017-04-01 17:33 UTC (History)
3 users (show)

Fixed In Version: sos-3.4-1.fc25 sos-3.4-1.fc26
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-03-31 02:23:13 UTC


Attachments (Terms of Use)

Description Yedidyah Bar David 2017-02-28 09:04:53 UTC
Description of problem:

$summary.

Seems to be caused by packaging. Upstream Makefile generates __init__.py from __init__.py.in, updating the version, but fedora spec probably does not call it. I think this is so since fc23. Not sure what's the best fix though.

Comment 1 Sandro Bonazzola 2017-03-29 08:20:04 UTC
Fixing 3.4 to report 3.4 instead of 3.2.

Comment 2 Fedora Update System 2017-03-29 08:32:12 UTC
sos-3.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-18edba8d64

Comment 3 Fedora Update System 2017-03-29 08:32:26 UTC
sos-3.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-03d1eae3be

Comment 4 Bryn M. Reeves 2017-03-29 10:07:04 UTC
It's because the Fedora builds moved from using the legacy Makefile based builds to the distutils build.

It's an upstream bug really, in that the checked-in version of sos/__init__.py was not updated for the 3.3/3.4 tarballs, and distutils builds from the tree do not know how to make this substitution.

Filed an issue upstream to address this by 3.5:

  https://github.com/sosreport/sos/issues/985

Comment 5 Fedora Update System 2017-03-29 17:50:14 UTC
sos-3.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-18edba8d64

Comment 6 Fedora Update System 2017-03-29 19:20:26 UTC
sos-3.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-03d1eae3be

Comment 7 Fedora Update System 2017-03-31 02:23:13 UTC
sos-3.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2017-04-01 17:33:52 UTC
sos-3.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.