Bug 142753 - Online resource group reconfiguration doesn't work
Summary: Online resource group reconfiguration doesn't work
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-13 21:02 UTC by Lon Hohberger
Modified: 2009-04-16 20:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 17:34:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lon Hohberger 2004-12-13 21:02:53 UTC
Description of problem:

SSIA.  Online reconfiguration does not work.

What needs to happen during a reconfiguration step (in this order):
(1) Resources which are running and have changed or been deleted must be stopped.
(2) Resource groups which have been removed must have their state set to
uninitialized.
(3) Resource groups which have been added must be initialized and the
stop-before-start portion must be run.
(4) Resources which have been added or changed must be started if they're part
of a previously running resource group.

A resource group change (such as a change of the name) will incur a full restart
of the resource group.

Comment 1 Lon Hohberger 2004-12-15 21:59:24 UTC
Working as stated.  When a resource is changed, all instances of that resource
and all of its children are restarted properly.

There's still nothing sending SIGHUP to clurgmgrd when a configuration changes.
 This is the job of ccsd or something equivalent (since ccsd knows *when* the
configuration changes).

Comment 2 Lon Hohberger 2005-03-02 17:34:03 UTC
rgmanager now polls ccsd for configuration updates.

Closing.


Note You need to log in before you can comment on or make changes to this bug.