Bug 142775 - Firefox always open external links in a new window
Summary: Firefox always open external links in a new window
Status: CLOSED DUPLICATE of bug 138789
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-14 00:17 UTC by Mariano Draghi
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to /usr/bin/firefox (787 bytes, patch)
2004-12-14 00:23 UTC, Mariano Draghi
no flags Details | Diff

Description Mariano Draghi 2004-12-14 00:17:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-AR; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Firefox always opens links from other (external) apps in a new browser
window, ignoring the "a new tab in the most recent window" user
preference.

Version-Release number of selected component (if applicable):
firefox-1.0-2.fc3

How reproducible:
Always

Steps to Reproduce:
1. Open Firefox
2. Go to Edit -> Preferences -> Advanced. Under Tabbed Browsing, Open
links from other applications in, choose "a new tab in the most recent
window" option. Click OK.
3. Open any URL (ex. http://google.com)
4. Open any other application (ex., your mail reader) and click on any
link
    

Actual Results:  Firefox opens a new window to show the content.

Expected Results:  Firefox should open a new TAB on the most recent
window.

Additional info:

I think the problem is Firefox's start up script (/usr/bin/firefox),
line 227. There's an explicit "new-window" parameter calling to
openurl() that overrides the user preferences. If you leave out the
new-window parameter, Firefox uses the user preference to decide
whether to open a new tab or window.

Comment 1 Mariano Draghi 2004-12-14 00:23:20 UTC
Created attachment 108479 [details]
Proposed patch to /usr/bin/firefox

Attached proposed patch

Comment 2 Warren Togami 2004-12-14 02:43:06 UTC

*** This bug has been marked as a duplicate of 138789 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:07:41 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.