Bug 142782 - eject failes to eject certain cds
eject failes to eject certain cds
Status: CLOSED DUPLICATE of bug 144913
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-13 20:32 EST by David Nielsen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-24 07:21:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2004-12-13 20:32:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; da-DK; rv:1.7.5)
Gecko/20041212 Firefox/1.0

Description of problem:
When ripping my cd collection I came across a problem where eject
would refuse to eject a certain CD, namely Metallica's St. Anger album.  

eject -v gives:

eject: using default device `cdrom'
eject: device name is `cdrom'
eject: expanded name is `/dev/cdrom'
eject: `/dev/cdrom' is a link to `/dev/hdc'
eject: `/dev/hdc' is not mounted
eject: `/dev/hdc' is not a mount point
eject: `/dev/hdc' is a multipartition device
eject: trying to eject `/dev/hdc' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: trying to eject `/dev/hdc' using SCSI commands
eject: SCSI eject failed
eject: trying to eject `/dev/hdc' using floppy eject command
eject: floppy eject command failed
eject: trying to eject `/dev/hdc' using tape offline command
eject: tape offline command failed
eject: unable to eject, last error: Invalid argument

Version-Release number of selected component (if applicable):
eject-2.0.13-13

How reproducible:
Always

Steps to Reproduce:
1. rip cd
2. eject    

Actual Results:  eject error message above

Expected Results:  succesful eject

Additional info:

running on a 14-12-04 Development system
Comment 1 David Nielsen 2004-12-14 10:33:49 EST
it seems that happens on every cd marked "Enhanced CD", which I take
means that it's a mixed mode cd.

So far: Slipknot "Vol 3: The subliminal verses" and Alanis Morissette
"Under Rug swept" also displayed this behavior.

Requiring a reboot to eject the CD isn't exactly optimal.
Comment 2 Ngo Than 2004-12-14 11:03:24 EST
if you press the eject button on your cdrom, does it work?
Comment 3 David Nielsen 2004-12-14 11:14:24 EST
No the drive is locked as if mounted.
Comment 4 Ngo Than 2004-12-14 12:12:04 EST
can you umount your cdrom?

if umount does not work, i assume that some running process still
opens the cdrom devices in this case. Please try to kill all this process
Comment 5 David Nielsen 2004-12-14 12:35:05 EST
Well the trick is that it isn't mounted, and trying to mount it gives
this:

/dev/hdc: Input/output error
mount: you didn't specify a filesystem type for /dev/hdc
       I will try all types mentioned in /etc/filesystems or
/proc/filesystems
Trying vfat
mount: block device /dev/hdc is write-protected, mounting read-only
/dev/hdc: Input/output error
mount: you didn't specify a filesystem type for /dev/hdc
       I will try all types mentioned in /etc/filesystems or
/proc/filesystems
Trying vfat
mount: /dev/hdc: can't read superblock

killing gnome-volume-manager (which I assume is to blame for mounting
such things) yields no improvement.
Comment 6 David Nielsen 2005-01-01 14:24:12 EST
This is still an issue as of 01-01-05, and a quite annoying one at that.

This bug isn't solely a Fedora problem btw. so there might be extra
input to be had on the issue.
https://bugzilla.ubuntu.com/show_bug.cgi?id=5049
Comment 7 Ngo Than 2005-08-24 07:21:54 EDT

*** This bug has been marked as a duplicate of 144913 ***

Note You need to log in before you can comment on or make changes to this bug.