Bug 142793 - 'yum update' fails with GPG error
'yum update' fails with GPG error
Status: CLOSED DUPLICATE of bug 138619
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-13 23:40 EST by Nathan Davis
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 15:54:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Davis 2004-12-13 23:40:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
I just installed a pristine copy of Fedora Core 3 (i386).  Immediately
after installation and configuration, I went to update with 'yum
update', but I got the following message:

You have enabled checking of packages via GPG keys. This is a good thing.
However, you do not have any GPG public keys installed. You need to
download
the keys for packages you wish to install and install them.
You can do that by running the command:
    rpm --import public.gpg.key
For more information contact your distribution or package provider.

Obviously, yum is working as expected, but it is reasonable to expect
to be able to update the system out of the box.

I selected the "workstation" install, and selected a few additional
packages.  Don't know if maybe some "magic package" was ommitted somehow.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install FC3
2. Run 'yum update' (as root)
3. Don't you love bugs?
    

Actual Results:  You have enabled checking of packages via GPG keys.
This is a good thing.
However, you do not have any GPG public keys installed. You need to
download
the keys for packages you wish to install and install them.
You can do that by running the command:
    rpm --import public.gpg.key
For more information contact your distribution or package provider.


Expected Results:  A check for $1 million ;-)

Additional info:
Comment 1 Sitsofe Wheeler 2004-12-14 04:40:46 EST
Well either the gpg key has to be installed by default (see bug #138619 ) or yum
has to default to not checking gpg signatures...
Comment 2 Nathan Davis 2004-12-20 13:44:44 EST
Yes, I agree with this assesment.  However, what is going to be done about it? 
I can see two options that would address the concerns mentioned in bug #138619:

1)  Prompt the user to accept the key.
2)  Configure yum to not check gpg signature.

Actually, there is a third, and that would be let the user decide between those
two.  In fact, I would say that is the best option -- just let the user decide.
Comment 3 Seth Vidal 2004-12-20 13:46:42 EST
which, of course, it does now. The user, if they don't want to import the key,
can just disable gpgchecking in your config file.
Comment 4 Nathan Davis 2004-12-20 17:09:56 EST
What I meant is that the installer should do this.
Comment 5 Rahul Sundaram 2005-06-20 15:54:25 EDT

*** This bug has been marked as a duplicate of 138619 ***

Note You need to log in before you can comment on or make changes to this bug.