Bug 1428008 - iDRAC get/set power state fails
Summary: iDRAC get/set power state fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-dracclient
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Dmitry Tantsur
QA Contact: nlevinki
URL:
Whiteboard:
Depends On: 1428005 1463224
Blocks: 1394872
TreeView+ depends on / blocked
 
Reported: 2017-03-01 17:10 UTC by Chris Dearborn
Modified: 2017-06-20 12:00 UTC (History)
18 users (show)

Fixed In Version: python-dracclient-1.1.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1428005
Environment:
Last Closed: 2017-05-17 20:03:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
Launchpad 1667088 None None None 2017-03-01 17:10:21 UTC

Description Chris Dearborn 2017-03-01 17:10:22 UTC
+++ This bug was initially created as a clone of Bug #1428005 +++

Description of problem:
There is a firmware bug in the iDRAC that causes ironic to fail to get/set the power state of the iDRAC.

This bug has been fixed upstream:
https://bugs.launchpad.net/python-dracclient/+bug/1667088

This BZ is to ensure the fix gets into OSP 11/Ocata.


Version-Release number of selected component (if applicable):
N/A.

How reproducible:
Try getting/setting the power state of a node where the iDRAC is exhibiting the firmware bug.

Steps to Reproduce:
1. See above.

Actual results:
Getting/Setting the iDRAC power state fails and the node is put into maintenance mode.

Expected results:
Getting/Setting the iDRAC power state should succeed.

Additional info:
N/A.

Comment 3 errata-xmlrpc 2017-05-17 20:03:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.