Bug 142812 - booleans files is not set to config(noreplace)
Summary: booleans files is not set to config(noreplace)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-14 13:30 UTC by Johannes Schmid
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: RHBA-2005-251
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 21:49:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:251 low SHIPPED_LIVE selinux-policy-targeted bug fix update 2005-06-09 04:00:00 UTC

Description Johannes Schmid 2004-12-14 13:30:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040910

Description of problem:
As the booleans file carries important information about the current
selinux configuration, it should not get replaced when updating the
selinux policy (thus causing some software to fail because the boolean
properties are reset to the default properties!)

Yes, I know, you were changing the format of the file from True/False
to 1/0 values, but this is no excuse :-) If neccessary, run a %post
script that updates the boolean file to the new format, but simply
overwriting a config file is never a good idea.


Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.51

How reproducible:
Always

Steps to Reproduce:
1. install selinux-policy-targeted
2. change booleans file
3. update the selinux-policy-targeted


    

Actual Results:  current (correct) config file will get renamed to
booleans.rpmsave, booleans is now the default config file 
-- your software breaks :-(

Expected Results:  new booleans will get saved as booleans.rpmnew, old
booleans is not touched.

Comment 1 Daniel Walsh 2004-12-17 21:12:55 UTC
Fixed in selinux-policy-targeted-1.17.30-2.53

Comment 2 Tim Powers 2005-06-09 13:06:03 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-251.html



Note You need to log in before you can comment on or make changes to this bug.