Bug 142815 - udev - logical tape wrong number
Summary: udev - logical tape wrong number
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: udev   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-14 14:02 UTC by Sammy
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 13:02:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2004-12-14 14:02:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) KHTML/3.3.2 (like Gecko)

Description of problem:
The logical device tape is linked to the wrong nstX. Must be a small
type. Here is my "ls -l tape*" listing:

lrwxrwxrwx  1 root root 5 Dec 14 01:53 tape -> nst0l
lrwxrwxrwx  1 root root 5 Dec 14 01:52 tape1 -> nst0a
lrwxrwxrwx  1 root root 5 Dec 14 01:53 tape2 -> nst0m
lrwxrwxrwx  1 root root 5 Dec 14 01:53 tape3 -> nst0a
lrwxrwxrwx  1 root root 4 Dec 14 01:53 tape4 -> nst0

tape needs to point to nst0.

This was probably present in the earlier version because I remember fixing
it.

Version-Release number of selected component (if applicable):
udev-0.48-1

How reproducible:
Always

Steps to Reproduce:
1.Install udev on a device with scsi tape
2.try to use /dev/tape device
3.
    

Additional info:

Comment 1 Harald Hoyer 2004-12-14 15:14:22 UTC
and how did the fix look like? :)

Comment 2 Sammy 2004-12-14 15:36:20 UTC
Oh... I did it by hand!

But I had reported the request for the logical link in October and
you fixed it and it was working correctly until recently. Whatever
reads from udev.rules and makes the link changed some logic.

Comment 3 Harald Hoyer 2004-12-14 15:54:34 UTC
Does this fix your problem??

diff -u -r1.16 udev.rules
--- udev.rules  13 Dec 2004 13:00:54 -0000      1.16
+++ udev.rules  14 Dec 2004 15:54:07 -0000
@@ -57,7 +57,7 @@
 KERNEL="scd[0-9]*",            SYMLINK="cdrom%e"
 KERNEL="pcd[0-9]*",            SYMLINK="cdrom%e"
 KERNEL="fd[0-9]*",             SYMLINK="floppy%e"
-KERNEL="nst[0-9]*",            SYMLINK="tape%e"
+KERNEL="nst[0-9]",             SYMLINK="tape%e"

 KERNEL="hd[a-z]", BUS="ide", SYSFS{removable}="1",
PROGRAM="/etc/udev/scripts/ide-media.sh %k", RESULT="floppy",
SYMLINK="floppy%e, NAME{ignore_remove, all_partitions}="%k"



Comment 4 Sammy 2004-12-14 16:50:52 UTC
With that I get:

lrwxrwxrwx  1 root root 4 Dec 14 04:48 /dev/tape -> nst0
lrwxrwxrwx  1 root root 4 Dec 14 04:48 /dev/tape1 -> nst0

this works for me since I only need this mode.


Note You need to log in before you can comment on or make changes to this bug.