Bug 1428246 - False positive warning message is printed out when mm KASLR code is not compiled in kernel
Summary: False positive warning message is printed out when mm KASLR code is not compi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Baoquan He
QA Contact: Qiao Zhao
URL:
Whiteboard:
: 1432322 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-02 06:38 UTC by Baoquan He
Modified: 2017-08-01 09:33 UTC (History)
4 users (show)

Fixed In Version: kexec-tools-2.0.14-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:33:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2300 0 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2017-08-01 12:40:58 UTC

Description Baoquan He 2017-03-02 06:38:18 UTC
Description of problem:
User space kexec-tools will search /proc/kallsyms for page_offset_base anyway to try to get page_offset. While page_offset_base definition and exporting codes are only available when mm KASLR code is compiled in kernel, otherwise it can't search anything and this is positive behaviour, there shoud be no error message printed out. Need fix it out.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Dave Young 2017-03-16 02:39:34 UTC
*** Bug 1432322 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2017-08-01 09:33:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2300


Note You need to log in before you can comment on or make changes to this bug.