Bug 1428256 - jboss-jsp-2.2-api: FTBFS in EPEL 7
Summary: jboss-jsp-2.2-api: FTBFS in EPEL 7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: jboss-jsp-2.2-api
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-02 07:05 UTC by gil cattaneo
Modified: 2017-05-30 16:54 UTC (History)
1 user (show)

Fixed In Version: jboss-jsp-2.2-api-1.0.1-15.1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 16:54:13 UTC
Type: Bug


Attachments (Terms of Use)

Description gil cattaneo 2017-03-02 07:05:54 UTC
Description of problem:
Package jboss-jsp-2.2-api fails to build from source in EPEL 7.

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-javadoc-plugin:2.9:aggregate (default-cli) on project jboss-jsp-api_2.2_spec: An error has occurred in JavaDocs report generation:
[ERROR] Exit code: 1 - /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/JspApplicationContext.java:122: error: unexpected end tag: </p>
[ERROR] * </ul></p>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/JspApplicationContext.java:133: error: unexpected end tag: </p>
[ERROR] * a <code>CompositeELResolver</code> that is already in the chain.</p>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/JspApplicationContext.java:89: error: unexpected end tag: </p>
[ERROR] * </p>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/JspContext.java:312: error: unexpected end tag: </p>
[ERROR] * </p>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/JspException.java:95: warning: no @param for message
[ERROR] public JspException(String message, Throwable cause) {
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/JspException.java:95: warning: no @param for cause
[ERROR] public JspException(String message, Throwable cause) {
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/JspException.java:108: warning: no @param for cause
[ERROR] public JspException(Throwable cause) {
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/BodyTag.java:115: error: self-closing element not allowed
[ERROR] * <IMG src="doc-files/BodyTagProtocol.gif"
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/IterationTag.java:89: error: self-closing element not allowed
[ERROR] * <IMG src="doc-files/IterationTagProtocol.gif"
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/JspIdConsumer.java:109: warning: no @param for id
[ERROR] public void setJspId(String id);
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/JspIdConsumer.java:92: error: unexpected end tag: </p>
[ERROR] * </p>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/Tag.java:102: error: unexpected end tag: </p>
[ERROR] * </ul></p>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/Tag.java:104: error: self-closing element not allowed
[ERROR] * <IMG src="doc-files/TagProtocol.gif"
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:122: error: self-closing element not allowed
[ERROR] * <IMG src="doc-files/VariableInfo-1.gif"
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:145: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *        bgcolor="#999999" summary="Variable Synchronization Points">
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:147: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" colspan="6" bgcolor="#999999"><u><b>Variable Synchronization
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:152: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <th valign="top" bgcolor="#c0c0c0">&nbsp;</th>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:153: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <th valign="top" bgcolor="#c0c0c0" align="center">doStartTag()</th>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:154: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <th valign="top" bgcolor="#c0c0c0" align="center">doInitBody()</th>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:155: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <th valign="top" bgcolor="#c0c0c0" align="center">doAfterBody()</th>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:156: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <th valign="top" bgcolor="#c0c0c0" align="center">doEndTag()</th>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:157: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <th valign="top" bgcolor="#c0c0c0" align="center">doTag()</th>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:160: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" bgcolor="#c0c0c0"><b>Tag<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:162: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, NESTED<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:164: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:166: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:168: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, AT_END<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:170: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:174: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" bgcolor="#c0c0c0"><b>IterationTag<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:176: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, NESTED<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:178: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:180: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, NESTED<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:182: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, AT_END<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:184: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:188: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" bgcolor="#c0c0c0"><b>BodyTag<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:190: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, NESTED<sup>1</sup><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:192: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, NESTED<sup>1</sup><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:194: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, NESTED<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:196: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, AT_END<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:198: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:202: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" bgcolor="#c0c0c0"><b>SimpleTag<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:204: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:206: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:208: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:210: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff"><br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/tagext/VariableInfo.java:212: warning: attribute obsolete, use CSS instead: bgcolor
[ERROR] *     <td valign="top" align="center" bgcolor="#ffffff">AT_BEGIN, AT_END<br>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ExpressionEvaluator.java:88: error: unexpected end tag: </p>
[ERROR] * </p>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:146: error: exception not thrown: javax.servlet.jsp.el.ELException
[ERROR] * @throws ELException if an exception was thrown while performing
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:233: error: exception not thrown: javax.servlet.jsp.el.ELException
[ERROR] * @throws ELException if an exception was thrown while performing
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:282: error: exception not thrown: javax.servlet.jsp.el.ELException
[ERROR] * @throws ELException if an exception was thrown while performing
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:330: error: exception not thrown: javax.servlet.jsp.el.ELException
[ERROR] * @throws ELException if an exception was thrown while performing
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:371: error: tag not allowed here: <li>
[ERROR] *     <li>displayName - The name of the implicit object.</li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:372: error: tag not allowed here: <li>
[ERROR] *     <li>name - Same as displayName property.</li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:373: error: tag not allowed here: <li>
[ERROR] *     <li>shortDescription - A suitable description for the implicit
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:375: error: tag not allowed here: <li>
[ERROR] *     <li>expert - <code>false</code></li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:376: error: tag not allowed here: <li>
[ERROR] *     <li>hidden - <code>false</code></li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:377: error: tag not allowed here: <li>
[ERROR] *     <li>preferred - <code>true</code></li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:382: error: tag not allowed here: <li>
[ERROR] *     <li>{@link ELResolver#TYPE} - The runtime type of the implicit object.</li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:383: error: tag not allowed here: <li>
[ERROR] *     <li>{@link ELResolver#RESOLVABLE_AT_DESIGN_TIME} - <code>true</code>.</li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:384: error: unexpected end tag: </p>
[ERROR] * </dl></p>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:95: error: end tag missing: </code>
[ERROR] *       <code>ServletRequest.getParameter(String name)).</li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ImplicitObjectELResolver.java:121: error: unexpected end tag: </p>
[ERROR] * </ul></p>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ScopedAttributeELResolver.java:272: error: tag not allowed here: <li>
[ERROR] *     <li>displayName - The name of the scoped attribute.</li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ScopedAttributeELResolver.java:273: error: tag not allowed here: <li>
[ERROR] *     <li>name - Same as displayName property.</li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ScopedAttributeELResolver.java:274: error: tag not allowed here: <li>
[ERROR] *     <li>shortDescription - A suitable description for the scoped
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ScopedAttributeELResolver.java:278: error: tag not allowed here: <li>
[ERROR] *     <li>expert - <code>false</code></li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ScopedAttributeELResolver.java:279: error: tag not allowed here: <li>
[ERROR] *     <li>hidden - <code>false</code></li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ScopedAttributeELResolver.java:280: error: tag not allowed here: <li>
[ERROR] *     <li>preferred - <code>true</code></li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ScopedAttributeELResolver.java:285: error: tag not allowed here: <li>
[ERROR] *     <li>{@link ELResolver#TYPE} - The current runtime type of the scoped attribute.</li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ScopedAttributeELResolver.java:286: error: tag not allowed here: <li>
[ERROR] *     <li>{@link ELResolver#RESOLVABLE_AT_DESIGN_TIME} - <code>true</code>.</li>
[ERROR] ^
[ERROR] /builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/src/main/java/javax/servlet/jsp/el/ScopedAttributeELResolver.java:287: error: unexpected end tag: </p>
[ERROR] * </dl></p>
[ERROR] ^
[ERROR] 
[ERROR] Command line was: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.102-4.b14.el7.aarch64/jre/../bin/javadoc @options @packages
[ERROR] 
[ERROR] Refer to the generated Javadoc files in '/builddir/build/BUILD/jboss-jsp-2.2-api-1.0.1.Final/target/site/apidocs' dir.
[ERROR] -> [Help 1]
Version-Release number of selected component (if applicable):
1.0.1-10.el7

Steps to Reproduce:
koji build --scratch epel7 jboss-jsp-2.2-api-1.0.1-10.el7.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/jboss-jsp-2.2-api

+ cd jboss-jsp-2.2-api-1.0.1.Final
+ mvn-rpmbuild install javadoc:aggregate
***************************************************************
* WARNING!  mvn-rpmbuild is deprecated and it will be removed *
* in future.  Users should migrate to using %mvn_build macro  *
* or call XMvn directly if greater flexibility is required.   *
***************************************************************

Comment 1 Michael Mráka 2017-05-11 06:25:31 UTC
commit a8dee825969c244ad6ebbc6e2e936c2b05d5d857
    Fixed FTBFS in EPEL7 RHBZ#1428256
    rebased to f26 and disabled doclint

Comment 2 Fedora Update System 2017-05-11 06:29:46 UTC
jboss-jsp-2.2-api-1.0.1-15.1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-8517a6ce4c

Comment 3 Fedora Update System 2017-05-12 19:55:56 UTC
jboss-jsp-2.2-api-1.0.1-15.1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-8517a6ce4c

Comment 4 Fedora Update System 2017-05-30 16:54:13 UTC
jboss-jsp-2.2-api-1.0.1-15.1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.