Bug 1428308 - Unable to commit period zonegroup change
Summary: Unable to commit period zonegroup change
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.3
Assignee: Matt Benjamin (redhat)
QA Contact: shilpa
URL:
Whiteboard:
: 1428309 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-02 09:40 UTC by Orit Wasserman
Modified: 2017-07-30 15:49 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-10.2.7-11.el7cp Ubuntu: ceph_10.2.7-12redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-19 13:30:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 17364 None None None 2017-03-02 09:40:19 UTC

Description Orit Wasserman 2017-03-02 09:40:19 UTC
Description of problem:

Cannot commit period after changing zonegroup

Version-Release number of selected component (if applicable):


How reproducible:
Update zone infromation on the default zonegroup and zone, try to update and commit the period.

Steps to Reproduce:
1.Update "default" zone by using radosgw-admin zone set commands
2.Update and commit the period using radosgw-admin period update --commit
3.

Actual results:
Error when commiting the period
Invalid configuration

Expected results:
Period commit successful

Additional info:

Comment 2 Vikhyat Umrao 2017-03-15 14:23:45 UTC
*** Bug 1428309 has been marked as a duplicate of this bug. ***

Comment 9 shilpa 2017-05-09 10:58:35 UTC
Verified on ceph-radosgw-10.2.7-14

Comment 11 errata-xmlrpc 2017-06-19 13:30:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.