Bug 1428326 - radosgw-admin period update reverts deleted zonegroup
Summary: radosgw-admin period update reverts deleted zonegroup
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.3
Assignee: Casey Bodley
QA Contact: shilpa
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-02 10:18 UTC by Orit Wasserman
Modified: 2017-07-30 15:42 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-19 13:30:12 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 17239 None None None 2017-03-02 10:18 UTC

Description Orit Wasserman 2017-03-02 10:18:39 UTC
Description of problem:







try 
the same error and zonegroup default is part of the staging period


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.start the radosgw without any multisite configuration (default zonegroup and zone will be created)
2.create a realm , set it as default.
3.update zonegroup default and zone default using set commands 
(this will cause the realm id to change)
4. update and commit the period
5. create a new master zonegroup zg0 and a new zg0zo that will the master of zg0
6. radosgw-admin period update --commit (error two master zonegroups)
7. remove zone default from default zonegroup and delete it
8. period update

Actual results:
error two master zonegroups and zonegroup default is part of the staging period

Expected results:
success

Additional info:
workround:
delete .rgw.root: rados purge .rgw.root --yes-i-really-really-mean-it
create a new configuration when the gateway is down:
create a new realm and set it as default
radosgw-admin zonegroup set < json (with the new realm id) 
radosgw-admin zoneg set < json (with the new realm id)
set zonegroup and zone as default
period update --commit

Comment 4 Matt Benjamin (redhat) 2017-04-04 16:37:30 UTC
@cbodley, @owasserm assigning to ensure backport

Comment 5 Orit Wasserman 2017-04-05 08:39:34 UTC
(In reply to Matt Benjamin (redhat) from comment #4)
> @cbodley, @owasserm assigning to ensure backport

It is part of Jewel 10.2.7, no need to backport

Comment 9 shilpa 2017-05-08 08:40:05 UTC
Verified on ceph-radosgw-10.2.7-13

Comment 11 errata-xmlrpc 2017-06-19 13:30:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.