Bug 14284 - /usr/bin/clear dumps core
Summary: /usr/bin/clear dumps core
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncurses   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-19 15:05 UTC by Brian Gunney
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-19 15:05:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Gunney 2000-07-19 15:05:07 UTC
/usr/bin/clear dumps core.

teton:~>5 which clear
/usr/bin/clear
teton:~>6 /usr/bin/clear
Segmentation fault (core dumped)
teton:~>7 file core
core: ELF 32-bit LSB core file of 'clear' (signal 11), Intel 80386, version
1
teton:~>8 rpm -qf /usr/bin/clear
ncurses-5.0-11

Kernel 2.2.14
Chip i686

Comment 1 Bernhard Rosenkraenzer 2000-07-19 17:03:49 UTC
Can't reproduce it. Did you modify any libraries or are you using some odd
terminal setting?

Comment 2 Brian Gunney 2000-07-21 21:06:58 UTC
Not using any strange terminal setting.  This occurs even in the text screen
and in single user mode.  Didn't modify any libraries, except for rpm updates
from RedHat and Gnome.

Comment 3 ville.sulko 2000-12-07 21:30:45 UTC
This one most certainly is a bug, it core-dumps for me too.
Using ncurses-5.0-12. The system is upgraded from previous RedHat
version, just can't remember which one (5.2 - 6.1). The same occurs
with (as an example) with 'tput kbs', which is called from bashrc.
Most annoying... Maybe someone could provide a ncurses package with
debugging information included, that would make resolving this one
easy...

$ ldd /usr/bin/clear
libncurses.so.4 => /usr/lib/libncurses.so.4 (0x4001a000)
libc.so.6 => /lib/libc.so.6 (0x40058000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)



Note You need to log in before you can comment on or make changes to this bug.