Bug 1428530 - Set NET_L3_MASTER_DEV=y to enable ipvlan module
Summary: Set NET_L3_MASTER_DEV=y to enable ipvlan module
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-02 18:47 UTC by Dan Williams
Modified: 2019-01-09 12:54 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-06 18:53:46 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Williams 2017-03-02 18:47:01 UTC
Fedora used to ship ipvlan.ko at one point, and even though we set CONFIG_IPVLAN=m it somehow that disappeared.  Seems like config-generic doesn't set NET_L3_MASTER_DEV=y which is now required for ipvlan due to 4fbae7d83.  That previously wasn't the case, so it probably just got missed.

(though that brings up the question, do we have any kind of automated QA like rpmdiff that warns when a module goes away unexpectedly?)

Comment 1 Laura Abbott 2017-03-02 19:11:24 UTC
I set the option back on, should be in tomorrow's rawhide build.

We don't have any sort of automated QA. There are some checks to verify that kernel config options match to a degree but this is a particular case that isn't caught.

Comment 2 Dan Williams 2017-03-02 20:54:01 UTC
ok thanks!

Comment 3 Dan Williams 2017-03-02 20:58:43 UTC
Could we get fix cherry-picked to f25 and (maybe?) f24 too?

Comment 4 Dan Williams 2017-05-09 17:13:13 UTC
Ping; any chance for F25 and F24 too?

Comment 5 Laura Abbott 2017-05-09 17:24:12 UTC
F24/F25 will be getting rebased to 4.11 in the near future so it should be picked up then.


Note You need to log in before you can comment on or make changes to this bug.