Bug 142862 - Hostnames at a glance
Hostnames at a glance
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-14 13:47 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-16 14:34:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
"FVTR_SDET.sh" (347 bytes, text/plain)
2004-12-14 17:27 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description Need Real Name 2004-12-14 13:47:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
If you have a lot of computers, it's helpful to see, at a glance,
which computer is which just by looking at the screen.

It would be nice if these was an option to set the wallpaper for a
machine to its hostname.

It would also be nice to have a text screensaver showing the same thing.

(and it would be nicer still to have a transparent screensaver showing
what the machine is doing)

Not sure where to assign.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 IBM Bug Proxy 2004-12-14 13:51:17 EST
----- Additional Comments From gjlynx@us.ibm.com(prefers email via gjohnson@austin.ibm.com)  2004-12-14 13:43 EDT -------
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=142861 
Comment 2 Need Real Name 2004-12-14 14:50:47 EST
Can you give me permission to view the bug? Thanks.
Comment 3 IBM Bug Proxy 2004-12-14 14:55:17 EST
----- Additional Comments From moilanen@us.ibm.com(prefers email via moilanen@austin.ibm.com)  2004-12-14 14:47 EDT -------
DEBUG_SLAB is a config option under: Kernel Hacking -> Debug memory allocations 
Comment 4 IBM Bug Proxy 2004-12-14 16:06:16 EST
----- Additional Comments From salina@us.ibm.com  2004-12-14 16:01 EDT -------
Carlos,
reboot the machine.  I rebuild kernel for you. 
Comment 5 IBM Bug Proxy 2004-12-14 16:10:13 EST
----- Additional Comments From salina@us.ibm.com  2004-12-14 16:02 EDT -------
Jake,
You want to use this kernel or latest David Howell kernel ? 
Comment 6 IBM Bug Proxy 2004-12-14 16:24:27 EST
----- Additional Comments From ameet@us.ibm.com  2004-12-14 16:14 EDT -------
I did some disassembly.  I could not objdump the entire trace, so I had to use 
the one provided by xmon.

In hash_page function,

read_lock(&pte_hash_lock[smp_processor_id()]);  <--this is instr ldx     
r0,r9,r6

        ptep = find_linux_pte(pgdir, ea); 
        /*
         * If no pte found or not present, send the problem up to
         * do_page_fault
         */
        if (ptep && pte_present(*ptep))  <--- this is cmpdi  cr7,r6,0.         
{
                ret = __hash_page(ea, access, vsid, ptep);
        } else {
                /* If no pte, send the problem up to do_page_fault */
                ret = 1; <--- Going with Jake's comment, I think it fails 
here. 

        }  
-------------------------------
#define pte_present(pte)       (pte_val(pte) & (_PAGE_P | _PAGE_PROTNONE))
#define pte_val(x) ((x).pte) 
Comment 7 IBM Bug Proxy 2004-12-14 17:27:32 EST
Created attachment 108573 [details]
"FVTR_SDET.sh"
Comment 8 IBM Bug Proxy 2004-12-14 17:28:54 EST
----- Additional Comments From scarlos@us.ibm.com  2004-12-14 17:18 EDT -------
 
SDET script

You can run this script with the new kernel. to try and recreate. 
Comment 9 IBM Bug Proxy 2004-12-14 17:29:44 EST
----- Additional Comments From scarlos@us.ibm.com  2004-12-14 17:19 EDT -------
SDET completed successfully on Power 4 650 box
hostname: ppc64hlp6.ltc.austin.ibm.com
ip: 9.3.190.136
uid: root
pwd: .pasroot 
Comment 10 IBM Bug Proxy 2004-12-14 17:43:34 EST
----- Additional Comments From scarlos@us.ibm.com  2004-12-14 17:31 EDT -------
The test was successful on power 4 650 and power 5 HV2 on RHEL4 pre-RC1 
Comment 11 IBM Bug Proxy 2004-12-14 17:49:14 EST
----- Additional Comments From scarlos@us.ibm.com  2004-12-14 17:40 EDT -------
Steps to run SDET:
1. mkdir /skyline
2. mount 9.3.192.95:/home/public /skyline
3. ./FVTR_SDET.sh 
Comment 12 IBM Bug Proxy 2004-12-14 17:55:12 EST
----- Additional Comments From robbiew@us.ibm.com  2004-12-14 17:47 EDT -------
This test passed on a Power4 AND an HV2 (Power5) with a higher version of
firmware.  We will flash this particular SF2 to the same level and attempt a
recreate. 
Comment 13 IBM Bug Proxy 2004-12-14 18:38:35 EST
----- Additional Comments From khoa@us.ibm.com  2004-12-14 18:26 EDT -------
Until we know more about this problem, I'd like to keep this bug in HIGH
severity.  If this turns out to be a true data corruption/miscompare problem,
we would need to bump the severity up at that point.  Thanks. 
Comment 14 IBM Bug Proxy 2004-12-14 19:10:29 EST
----- Additional Comments From salina@us.ibm.com  2004-12-14 19:05 EDT -------
Carlos udpated firmware.. SDET restarted.  Robbie will keep track and update. 
Comment 15 Need Real Name 2004-12-15 03:13:09 EST
Erm, IBM people - this bug number is for a "hostnames as wallpaper"
request, not a kernel bug..
Comment 16 Alexander Larsson 2004-12-15 04:25:21 EST
Uhm? What the heck?
Glen: Why are you adding some kernel stuff to this bug?
Comment 17 IBM Bug Proxy 2004-12-15 11:39:19 EST
----- Additional Comments From robbiew@us.ibm.com  2004-12-15 11:30 EDT -------
Test Run Update - The test is still running and the machine is still up and
responsive. :) 
Comment 18 IBM Bug Proxy 2004-12-15 16:43:40 EST
----- Additional Comments From robbiew@us.ibm.com  2004-12-15 16:31 EDT -------
Test update - Still running with no problems. 
Comment 19 IBM Bug Proxy 2004-12-16 11:05:12 EST
----- Additional Comments From robbiew@us.ibm.com  2004-12-16 11:00 EDT -------
Testing completed without problems. 
Comment 20 IBM Bug Proxy 2004-12-16 12:24:25 EST
----- Additional Comments From mjwolf@us.ibm.com  2004-12-16 12:15 EDT -------
testing completed on the FW that originally exhibited the problem or the updated
FW?  If the tests completed on the updated FW, please put the 'older' FW on and
re-run the test.  Want to make sure this problem can be recreated. 
Comment 21 IBM Bug Proxy 2004-12-16 12:35:49 EST
----- Additional Comments From robbiew@us.ibm.com  2004-12-16 12:22 EDT -------
It completed with the new FW.  Comment #28 stated that the tester was able to
recreate twice on the older FW.  What do we gain by going back to the older FW
and recreating for a third time? 
Comment 22 IBM Bug Proxy 2004-12-16 14:29:10 EST
----- Additional Comments From scheel@us.ibm.com  2004-12-16 14:16 EDT -------
We need root cause for this defect, even if it means going back to old firmware. 
Comment 23 IBM Bug Proxy 2004-12-17 11:17:41 EST
----- Additional Comments From robbiew@us.ibm.com  2004-12-17 11:10 EDT -------
I flashed the machine to the oldest firmware available from the firmware
download site...and the test still passed.  I was put in contact with someone
who can get the actual old level I need (b0824a_0434.220).  As soon as I receive
this level, I will flash and re-test. 
Comment 24 IBM Bug Proxy 2004-12-17 13:10:03 EST
----- Additional Comments From robbiew@us.ibm.com  2004-12-17 13:01 EDT -------
I've flashed to b0824a_0434.220 and will update on the status of the recreate
attempt. 
Comment 25 IBM Bug Proxy 2004-12-20 11:00:10 EST
----- Additional Comments From robbiew@us.ibm.com  2004-12-20 10:55 EDT -------
Ran the test for the full 24 hours with b0824a_0434.220 and no recreate. I think
all we can do now is close as unreproducible. 
Comment 26 IBM Bug Proxy 2004-12-20 11:10:30 EST
----- Additional Comments From robbiew@us.ibm.com  2004-12-20 11:04 EDT -------
Closing as unreproducible. We will run this again on the next RC2 (12/20)
release, on this same machine and firmware...to make sure. 
Comment 27 IBM Bug Proxy 2005-01-10 10:55:04 EST
----- Additional Comments From moilanen@us.ibm.com(prefers email via moilanen@austin.ibm.com)  2005-01-10 10:47 EST -------
Reclosing as unreproducable.  Please reopen if it's hit again. 
Comment 28 IBM Bug Proxy 2005-03-08 09:57:48 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REJECTED                    |CLOSED




------- Additional Comments From scarlos@us.ibm.com  2005-03-08 09:56 EST -------
ok will try on latest RHEL4 RC3 again and see if it reoccurs. Will Close for 
now. 

Note You need to log in before you can comment on or make changes to this bug.