Bug 1428654 - Need a better error message when a cluster id with no bricks is provided
Summary: Need a better error message when a cluster id with no bricks is provided
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: cns-3.5
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
: CNS 3.10
Assignee: John Mulligan
QA Contact: vinutha
URL:
Whiteboard:
Depends On:
Blocks: 1568861
TreeView+ depends on / blocked
 
Reported: 2017-03-03 03:30 UTC by krishnaram Karthick
Modified: 2019-02-12 05:45 UTC (History)
9 users (show)

Fixed In Version: heketi-6.0.0-14.el7rhgs
Doc Type: Bug Fix
Doc Text:
Previously, heketi attempted to allocate a volume by iterating over all available clusters to determine where a volume request would fit. If none of the clusters were suitable Heketi returned a generic "No space" error. This generic error hid useful debugging information from the user. With this fix, Heketi gathers all the error conditions from the clusters into a single error response. If more than one cluster is configured the error for each cluster is prefixed with the cluster's ID.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:22:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github heketi heketi issues 712 0 None None None 2018-05-07 16:20:25 UTC
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:23:25 UTC

Description krishnaram Karthick 2017-03-03 03:30:59 UTC
Description of problem:

When a cluster is created manually without any nodes or bricks and when such a cluster id is defined as part of storage class, pvc creation fails with 'Error calling v.allocBricksInCluster: Id not found'. Looks like we just return the error received from the function. A better error message should be provided.

p.s., This bug is more of an enhancement, uncovered during negative test. Regular workflow of CNS will not end up in this scenario.

[root@dhcp46-201 ~]# heketi-cli cluster info 75f2bdc4e362b8f78833af932f0ebcf9
Cluster id: 75f2bdc4e362b8f78833af932f0ebcf9
Nodes:

[root@dhcp46-201 ~]# cat storageclass_voltype 
apiVersion: storage.k8s.io/v1beta1
kind: StorageClass
metadata:
  name: voltypenegative 
provisioner: kubernetes.io/glusterfs
parameters:
  resturl: "http://heketi-storage-project.cloudapps.mystorage.com"
  restuser: "test"
  clusterid: "75f2bdc4e362b8f78833af932f0ebcf9"

[root@dhcp46-201 ~]# oc describe pvc/clusterid
Name:		clusterid
Namespace:	storage-project
StorageClass:	voltypenegative
Status:		Pending
Volume:		
Labels:		<none>
Capacity:	
Access Modes:	
Events:
  FirstSeen	LastSeen	Count	From				SubObjectPath	Type		Reason			Message
  ---------	--------	-----	----				-------------	--------	------			-------
  21s		11s		2	{persistentvolume-controller }			Warning		ProvisioningFailed	Failed to provision volume with StorageClass "voltypenegative": glusterfs: create volume err: error creating volume Error calling v.allocBricksInCluster: Id not found.

Version-Release number of selected component (if applicable):
# rpm -qa | grep 'heketi'
heketi-client-4.0.0-1.el7rhgs.x86_64
# oc version
oc v3.5.0.37
kubernetes v1.5.2+43a9be4
features: Basic-Auth GSSAPI Kerberos SPNEGO

openshift v3.5.0.37
kubernetes v1.5.2+43a9be4


How reproducible:
always

Steps to Reproduce:
provided along with the description

Comment 2 Humble Chirammal 2017-03-03 06:05:31 UTC
This is the error returned from Heketi. In the same scenario if we try 'heketi-cli' you will land into same error. This has to be fixed at heketi layer.  I will change the componenet back to Heketi and open an issue at heketi upstream.

Comment 3 Humble Chirammal 2017-03-06 10:54:53 UTC
@Karthick, can you please open an upstream heketi issue for a better error message, please let me know if you need any help.

Comment 4 krishnaram Karthick 2017-03-13 15:39:38 UTC
(In reply to Humble Chirammal from comment #3)
> @Karthick, can you please open an upstream heketi issue for a better error
> message, please let me know if you need any help.

Upstream heketi bug raised - https://github.com/heketi/heketi/issues/712

Comment 8 John Mulligan 2018-05-29 19:33:17 UTC
https://github.com/heketi/heketi/pull/1199

Comment 12 Anjana KD 2018-08-30 13:59:27 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 13 John Mulligan 2018-08-30 17:14:23 UTC
Doc Text LGTM

Comment 15 errata-xmlrpc 2018-09-12 09:22:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686


Note You need to log in before you can comment on or make changes to this bug.