Bug 1428707 - [atomic registry] Didn't sync projects when new project created
Summary: [atomic registry] Didn't sync projects when new project created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Jordan Liggitt
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1447441
TreeView+ depends on / blocked
 
Reported: 2017-03-03 08:32 UTC by XiaochuanWang
Modified: 2017-08-16 19:51 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1447441 (view as bug list)
Environment:
Last Closed: 2017-08-10 05:18:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
duplicate project on overview when create new projects (32.29 KB, image/png)
2017-03-03 08:32 UTC, XiaochuanWang
no flags Details
screen record for cockpit 135 (1.25 MB, image/gif)
2017-05-02 03:36 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1716 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.6 RPM Release Advisory 2017-08-10 09:02:50 UTC

Description XiaochuanWang 2017-03-03 08:32:00 UTC
Created attachment 1259423 [details]
duplicate project on overview when create new projects

Description of problem:
New project created from Project page is missing from Project page and duplicate on Overview page.

Version-Release number of selected component (if applicable):
openshift3/registry-console:3.5

How reproducible:
Always

Steps to Reproduce:
1. Create a project by "New Project" from Projects page, input a name for new project and hit "Create"
2. Go to Overview page by clicking Overview from left panel. 
3. Refresh Overview page

Actual results:
1. There is not new project display on Project page.
2. There is duplicated project listed on Overview page. Top-right corner shows "Ooops!"
3. Project display correctly.

Expected results:
1. New project should be displayed on Project page as soon as new project created.
2. There should be new project listed correctly on Overview page, not duplicated project name.

Additional info:
If create a project on Overview page, there is no project duplication, but go to Projects page and go back to Overview page by left panel, the issue in Actual step 2 could be seen.

Comment 1 Peter 2017-05-01 17:30:07 UTC
I was unable to reproduce with cockpit 126 or 139 (on Fedora 25). New project displayed correctly everywhere both before and after refresh. Are you still able to reproduce? If so can you add any console output you get to the ticket. If there is an oops, something should be there.

Comment 2 XiaochuanWang 2017-05-02 03:36:45 UTC
Created attachment 1275544 [details]
screen record for cockpit 135

Comment 3 Peter 2017-05-02 04:23:00 UTC
Very strange, same steps don't reproduce it for me. What version of origin/openshift is the registry running against?

Comment 4 XiaochuanWang 2017-05-02 05:33:48 UTC
Version: Cockpit 135
1. Create project on project page, go to Overview directly, duplicated project is seen.
2. Create project on Overview page, go to project page and then go back, duplicated project is seen
3. Refresh Overview page, duplicated project is gone, (but can not delete existed projects)

Comment 5 XiaochuanWang 2017-05-02 05:36:59 UTC
Cockpit Version 135.
Licensed under: GNU LGPL version 2.1  
OpenShift Master:     v3.5.5.10
Kubernetes Master:     v1.5.2+43a9be4

Comment 6 Peter 2017-05-02 14:27:43 UTC
Thanks able to reproduce now. This is caused by the selfLink regression in openshift.

https://github.com/openshift/origin/issues/12553

I'll see if this warrents a fix to cockpit or if we can rely on it getting fixed in openshift.

Comment 7 Peter 2017-05-02 14:49:41 UTC
Since this is now fixed upstream in kubernetes https://github.com/kubernetes/kubernetes/pull/44462. I think it's reasonable to get that fix backported.

Comment 8 Jessica Forrester 2017-05-02 15:02:42 UTC
Based on discussion in the issue it looks like andy's team has been owning getting this fixed, reassigning to them.

Comment 9 Andy Goldstein 2017-05-02 15:19:56 UTC
This will be fixed in 3.6 via https://github.com/openshift/origin/pull/14001. Do we need this backported to 3.5.x?

Comment 10 Peter 2017-05-02 15:22:29 UTC
I would recommend that we do. Broken selfLinks will cause a lot of other regressions in the registry. But I'll leave it up to PM to make the call.

Comment 11 Andy Goldstein 2017-05-02 18:36:29 UTC
Eric, backport yes/no?

Comment 13 Eric Paris 2017-05-02 19:13:52 UTC
https://github.com/openshift/origin/pull/14001

Comment 15 XiaochuanWang 2017-05-31 08:41:14 UTC
Not reproduce on 3.6
openshift v3.6.86
kubernetes v1.6.1+5115d708d7
Cockpit Version 131. 

Since it need to backport to OCP 3.5, tested on v3.5.5.20
It is blocked by bug 1457141

Comment 18 errata-xmlrpc 2017-08-10 05:18:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716


Note You need to log in before you can comment on or make changes to this bug.