Bug 142874 - Assertion failed on line 128 of file /home/snark/code/head/cluster/dlm-kernel/src/reccomms.c
Assertion failed on line 128 of file /home/snark/code/head/cluster/dlm-kernel...
Status: CLOSED DUPLICATE of bug 142844
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: dlm (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Teigland
Cluster QE
:
Depends On:
Blocks: 133240
  Show dependency treegraph
 
Reported: 2004-12-14 16:10 EST by michael conrad tadpol tilstra
Modified: 2009-04-16 16:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dumps from dlm (57.63 KB, text/plain)
2004-12-14 16:14 EST, michael conrad tadpol tilstra
no flags Details
Full dlm assert dump (39.12 KB, application/x-bzip2)
2004-12-16 14:36 EST, michael conrad tadpol tilstra
no flags Details
email describing how this bug was hit (8.46 KB, text/plain)
2004-12-17 19:58 EST, Need Real Name
no flags Details

  None (edit)
Description michael conrad tadpol tilstra 2004-12-14 16:14:24 EST
Created attachment 108570 [details]
dumps from dlm

Again, not sure if this is everything, think I'm limited by the scrollback
buffer again.
Comment 1 michael conrad tadpol tilstra 2004-12-16 14:36:32 EST
Created attachment 108739 [details]
Full dlm assert dump

Got this one again. (finally)

Turned on screen logging, got full output this time.  Also included output from

other nodes.  clocks are synced accross all nodes.
Comment 2 Need Real Name 2004-12-17 19:58:32 EST
Created attachment 108836 [details]
email describing how this bug was hit

This is a copy of the email sent on the linux-cluster mailing list.
Comment 3 David Teigland 2004-12-30 03:32:31 EST
When the dlm reports -ENOBUFS (-105) it means that no kernel memory
could be allocated to send a network message.  Obviously, the reccomms
function asserts when it sees this, and the remote_stage function
doesn't (but it probably should.)

It's not clear that there's anything wrong with the dlm here.  Reducing
the drop_count in lock_dlm might help simply by causing gfs to cache
fewer locks and reduce memory usage.
Comment 4 David Teigland 2004-12-30 03:58:31 EST
comment #3 is related to bug 139738, not this one
Comment 5 David Teigland 2005-01-04 03:05:30 EST

*** This bug has been marked as a duplicate of 142844 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:07:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.