Bug 1428805 - abrt-cli can't used by check_mk
Summary: abrt-cli can't used by check_mk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.3
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-03 11:54 UTC by Frank Büttner
Modified: 2018-10-30 10:01 UTC (History)
7 users (show)

Fixed In Version: selinux-policy-3.13.1-203.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:00:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:01:02 UTC

Description Frank Büttner 2017-03-03 11:54:28 UTC
Description of problem:
When using check_mk to check for software/kernel crashes via abrt-cli the fails with the selinux error:
type=USER_AVC msg=audit(1488540923.739:3609): pid=702 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } for msgtype=method_return dest=:1.1796 spid=91003 tpid=95891 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:system_r:inetd_child_t:s0-s0:c0.c1023 tclass=dbus  exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'


Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-102.el7_3.13.noarch

How reproducible:
Every time

Steps to Reproduce:
1. call "nc hostname port" of the system on which check-mk is running

Actual results:
The error above.

Expected results:
working check-mk

Additional info:
This new role is needed:
module checkMK 2.0;

require {        
        type inetd_child_t;
        type abrt_t;
        class dbus send_msg;
}
#============= abrt_t ==============
allow abrt_t inetd_child_t:dbus send_msg;

Comment 7 errata-xmlrpc 2018-10-30 10:00:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.