Bug 1428935 - /etc/rc.d/init.d/functions is missing rhel6 functionality
Summary: /etc/rc.d/init.d/functions is missing rhel6 functionality
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: Leos Pol
Filip Hanzelka
URL:
Whiteboard:
Depends On:
Blocks: 1420851
TreeView+ depends on / blocked
 
Reported: 2017-03-03 16:16 UTC by Martin Poole
Modified: 2017-08-01 07:31 UTC (History)
2 users (show)

Fixed In Version: initscripts-9.49.38-1.el7
Doc Type: Enhancement
Doc Text:
Backward compatibility enabled for "killproc()" and "status()" Prior to this update, the `/etc/rc.d/init.d/functions` script shipped in Red Hat Enterprise Linux 7 lacked some of the features of the Red Hat Enterprise Linux 6 counterpart. The _initscripts_ package has been updated to add support for the "-b" option to the "killproc()" and "status()" functions in the `/etc/rc.d/init.d/functions` file. This addition enables backward compatibility for Red Hat Enterprise Linux 6 and prevents possible regressions when performing an upgrade from Red Hat Enterprise Linux 6 to Red Hat Enterprise Linux 7.
Clone Of:
Environment:
Last Closed: 2017-08-01 07:31:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2286 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2017-08-01 11:26:43 UTC

Description Martin Poole 2017-03-03 16:16:47 UTC
Description of problem:

The /etc/rc.d/init.d/functions scripts shipped in RHEL7 are missing some of the features of the RHEL6 counterpart, making backward compatiblity fail.

__pids_var_run()
killproc()
status()

are all missing the option -b binary

Version-Release number of selected component (if applicable):

initscripts-9.49.37-1.el7.x86_64

Comment 2 David Kaspar [Dee'Kej] 2017-03-08 13:32:13 UTC
Hello Martin,

first of all - __pids_var_run() in RHEL6 does not have '-b' option AFAIK, because it does not need it. It's an internal function of initscripts, and calling it directly is *NOT SUPPORTED* by initscripts (and thus by Red Hat).

Nevertheless, I will look into the option to to do a forward backport of patch from RHEL-6 to RHEL-7.

Comment 5 David Kaspar [Dee'Kej] 2017-03-24 15:53:00 UTC
Pull-request submitted:
https://github.com/fedora-sysv/initscripts/pull/83

Comment 6 David Kaspar [Dee'Kej] 2017-03-30 15:08:21 UTC
Commit was merged into RHEL-7 branch.

Comment 10 Leos Pol 2017-07-07 14:28:38 UTC
Verified by TC.

Comment 12 errata-xmlrpc 2017-08-01 07:31:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2286


Note You need to log in before you can comment on or make changes to this bug.