Bug 1428947 - percpu_ida: Use local locks
Summary: percpu_ida: Use local locks
Keywords:
Status: CLOSED DUPLICATE of bug 1430926
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel-rt
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: John Kacur
QA Contact: Jiri Kastner
URL:
Whiteboard:
Depends On:
Blocks: 1353018 1410158
TreeView+ depends on / blocked
 
Reported: 2017-03-03 16:32 UTC by John Kacur
Modified: 2017-03-14 13:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-14 13:55:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description John Kacur 2017-03-03 16:32:56 UTC
the local_irq_save() + spin_lock() does not work that well on -RT


convert to local_lock_irqsave(irq_off_lock, flags);

Comment 2 John Kacur 2017-03-14 13:55:57 UTC

*** This bug has been marked as a duplicate of bug 1430926 ***


Note You need to log in before you can comment on or make changes to this bug.