Bug 1428997 - Port wxGTK3 to webkit2
Summary: Port wxGTK3 to webkit2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wxGTK3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Scott Talbert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-03 18:55 UTC by Jeremy Newton
Modified: 2017-05-16 20:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-16 20:23:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Jeremy Newton 2017-03-03 18:55:12 UTC
Tracker bug for porting wxGTK3 from webkitgtk3 to webkit2.

See Bug #1375846 for details and history.

See upstream ticket:
http://trac.wxwidgets.org/ticket/17650

Comment 1 Scott Talbert 2017-03-23 23:56:38 UTC
Pull request submitted upstream:
https://github.com/wxWidgets/wxWidgets/pull/439

Comment 2 Jeremy Newton 2017-05-02 18:33:31 UTC
Can we push this as fixed with the 3.0.3 update? or did this only land in master?

If so, can you just update the patch to the final implementation, and we can include this in the 3.0.3 update push?

Comment 3 Scott Talbert 2017-05-03 01:03:19 UTC
(In reply to Jeremy Newton from comment #2)
> Can we push this as fixed with the 3.0.3 update? or did this only land in
> master?
> 
> If so, can you just update the patch to the final implementation, and we can
> include this in the 3.0.3 update push?

It has only been merged in master, and I've got another pull request pending for the 3.0 backport.  It was only held off because they didn't feel comfortable merging it just before 3.0.3 release.   I don't anticipate any changes, since the backport is almost identical to the original patch.  Thus, I think it is fine for us to update to the latest patch.  I'll go ahead and work on that and the 3.0.3 update tonight.

Comment 4 Jeremy Newton 2017-05-03 20:53:44 UTC
(In reply to Scott Talbert from comment #3)
> (In reply to Jeremy Newton from comment #2)
> > Can we push this as fixed with the 3.0.3 update? or did this only land in
> > master?
> > 
> > If so, can you just update the patch to the final implementation, and we can
> > include this in the 3.0.3 update push?
> 
> It has only been merged in master, and I've got another pull request pending
> for the 3.0 backport.  It was only held off because they didn't feel
> comfortable merging it just before 3.0.3 release.   I don't anticipate any
> changes, since the backport is almost identical to the original patch. 
> Thus, I think it is fine for us to update to the latest patch.  I'll go
> ahead and work on that and the 3.0.3 update tonight.

Ah, yes, if you would rather avoid pushing the webkit2 patch to Fedora 24/25/26 (to avoid any regression), you could wrap the webkit2 stuff in a "if fedora > 26" or whatever the syntax is.

Thanks for your help!

Comment 5 Fedora Update System 2017-05-06 02:06:21 UTC
wxGTK3-3.0.3-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ef19872468

Comment 6 Fedora Update System 2017-05-07 05:08:05 UTC
wxGTK3-3.0.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ef19872468

Comment 7 Fedora Update System 2017-05-09 00:53:52 UTC
wxGTK3-3.0.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-901ccd6490

Comment 8 Fedora Update System 2017-05-10 07:04:17 UTC
wxGTK3-3.0.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-901ccd6490

Comment 9 Fedora Update System 2017-05-15 12:52:25 UTC
wxGTK3-3.0.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-05-16 06:01:16 UTC
wxGTK3-3.0.3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Jeremy Newton 2017-05-16 20:23:48 UTC
Thanks Scott!


Note You need to log in before you can comment on or make changes to this bug.