Bug 1429 - xdm cant find user's config files if autofs is used
Summary: xdm cant find user's config files if autofs is used
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 5.2
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-05 14:21 UTC by a.hentz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-19 19:00:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description a.hentz 1999-03-05 14:21:17 UTC
When we mount /home using automount and xdm, users loose
their configurations (.fvwmrc, .wm_syle). That happens
because Xsession test for the presence of these files in  a
direcory that was not yet mounted. A possible solution is to
add the following two lines to the beginninng of Xsession:
	pushd $HOME
	popd

Comment 1 David Lawrence 1999-03-18 16:29:59 UTC
The first phase of Xsession should make sure that a users home
directory is properly mounted. Thank you for the suggestion.

Comment 2 Preston Brown 1999-03-19 19:00:59 UTC
I have been testing this, and a test of the format:

if [ -f /some/path/to/file/filename.ext ]; then
	echo true
else
	echo false
fi

Seems to produce the desired results, i.e. if the filesystem isn't
mounted, the test causes the filesystem to get mounted and then the
command returns true.  Therefore if the system you are using is
configured correctly, when we "test for files that aren't mounted yet"
autofs should be mounting the filesystem and then doing the test.

I can't reproduce the problem here is what I am saying.


Note You need to log in before you can comment on or make changes to this bug.