Bug 14290 - X eats up cpu
Summary: X eats up cpu
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-19 17:50 UTC by doug
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-19 16:09:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description doug 2000-07-19 17:50:35 UTC
I'm running an upgraded RedHat 6.2 system to get the
XFree86-4.0.1-30.i386.rpm to run.  I don't remember how many packages I had
to upgrade to get it working.  I have two graphics cards (matrox g400 sh,
guillemont riva tnt2 m64).  I am not using the nvidia custom drivers, just
the nvidia drivers in the rpm.  I am running in xinerama mode.  My kernel
is 2.2.16-3 from rpm.  I am also running enlightenment 16.4 from cvs.  What
happens is that after my X session has been running a while, X will start
churning.  It doesn't go into a "tight loop", but it does eat the cpu.  It
typically stays around 50% cpu usage according to 'top'.  The only solution
is to restart the X session.  Of course, everything else seems to run slow
when X gets into this state.

Comment 1 Bill Nottingham 2000-08-14 23:05:01 UTC
Does this persist with the latest X packages?

Comment 2 doug 2000-08-15 01:29:11 UTC
I will check and post results.  However, I upgraded my enlightenment to latest
cvs.  I still have problem, but it doesn't occur as frequently.  Please note
that 'top' reports that 'X' is eating up cpu.  Of course, enlightenment works
closely with X.

Comment 3 doug 2000-08-16 15:51:14 UTC
I am unable to upgrade to XFree86-4.0.1-0.43.i386.rpm because I only have
rpm-3.0.5-0.5 installed on my system.  I can't figure out how to upgrade to
rpm-4x without installing the beta RH7.0.

Comment 4 Bill Nottingham 2000-08-16 21:59:30 UTC
The -30 package was compiled by a compiler with
a bug that could cause strange X server behavior, that's
why I'm mentioning this.

You should be able to use the latest 3.0.5 RPM at
ftp://ftp.redhat.com/pub/redhat/updates/6.2/i386
to install later X packages.

Comment 5 doug 2000-08-17 15:31:33 UTC
OK, I'm running XFree86-4.0.1-0.43 now.  I'll post in another day to report if I
see the same behaviour or not.

Comment 6 doug 2000-08-19 16:09:40 UTC
I cam in this morning and found X running at 47% CPU.  I leave X running for
several days.  This particular session has been up since Aug 17 (when I
installed the -0.43 packages).

I just glanced over at top and found that X was only at 15%.  I had an Eterm
running top covering an XEmacs window.  I thought, "maybe XEmacs is what is
causing the problem."  So, I exposed XEmacs and moved the window around with the
titlebar.  Of course, X cpu usage went up while I was dragging the window
around.  I actually got it as high as 80%.  Now I've been waiting for about five
minutes and X has been steady around 50%.

I'm not sure what this points to; maybe the window manager (Enlightenment cvs)? 
I will post to the enlightenment-devel mailing list and see what they think.

Comment 7 Bill Nottingham 2000-08-19 22:16:46 UTC
It does sound like an enlightenment problem; I haven't
heard any reports of this here with our enlightenment
packages, or with other window managers.


Note You need to log in before you can comment on or make changes to this bug.