Bug 142900 - bugzilla users displayed by name rather than email address
bugzilla users displayed by name rather than email address
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
Mike MacKenzie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-14 17:43 EST by Geoff Gustafson
Modified: 2007-04-18 13:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 02:46:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Gustafson 2004-12-14 17:43:00 EST
Description of problem:
This is obviously by design, but I definitely used to notice when the bug
reporter was from Red Hat or a vendor or the great beyond, based on their email
address, which is now not immediately visible.

It was pointed out on IRC that the names are mailto: links, so I believe that
hovering over the name will be a reasonable workaround, but I wouldn't be
surprised if this bites someone at some point when they don't realize who
they're talking to.

Another thing to consider is you could highlight non-RHers in a noticeable color
(and for instance I could be blacklisted if you like).

I'm definitely glad the CC: list is still email addresses, because you can
quickly scan it for alternate domain names.
Comment 1 David Lawrence 2004-12-14 17:54:14 EST
Well the entire reason for the email address changes was to 1) get more screen
real estate and 2) hides email addresses from no logged in users to help repel
spam robots looking for addresses. The Cc list needs to be sanitized as well for
non logged in users but is not yet complete. I will look into changing the email
format for logged in users to be instead:

Real Name <email@domain.com>

Comment 2 David Lawrence 2005-02-23 02:46:04 EST
Should be addressed now. Closing.

Note You need to log in before you can comment on or make changes to this bug.