Bug 142909 - RHEL4 -- /etc/fstab not updated when USB storage devices are plugged in
Summary: RHEL4 -- /etc/fstab not updated when USB storage devices are plugged in
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: hal   
(Show other bugs)
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-14 23:03 UTC by Stuart Hayes
Modified: 2013-03-06 03:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-23 00:26:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stuart Hayes 2004-12-14 23:03:49 UTC
Description of problem:

When a USB floppy drive, cdrom drive or key drive is plugged in any 
PE with RHEL4 pre-rc1(x86), /var/log/messages records the device 
being detected, but /etc/fstab is not updated with the new mount 
information. The mount point under /media is not created.

There is no problem mounting the device manually.



Version-Release number of selected component (if applicable):

Using hal-0.4.0-9 and kernel 2.6.9-1.860_ELsmp

How reproducible:
easy

Steps to Reproduce:
1. Install RHEL4 Pre-RC1 with kernel 2.6.9-1.860_ELsmp
2. Plug in a USB cdrom/floppy/key drive
3. Observe /var/log/message to verify that the new device is 
recognized by the OS
4. Check /etc/fstab for any new entries and /media for any new 
directories 
  
Actual results:
the added USB device isn't automounted, nothing is added to /etc/fstab

Expected results:
device automounted in /media, and entry added to /etc/fstab

Additional info:
It appears that the usb devices don't even have an info.category when 
i look at the output of 'lshal'.  It also appears that the storage-
policy.fdi won't mount a storage device if info.category isn't set 
to 'storage'.

I'm not sure if this is intentional or not... nor am I sure who or 
what would normally set info.category to storage and that sort of 
thing.  This key/property (info.category) does seem to be set for the 
IDE cd-rom and the legacy floppy.

Comment 1 David Zeuthen 2004-12-15 02:02:23 UTC
I think this is fixed in the 0.4.2 hal rpm's available here

 http://people.redhat.com/davidz/rhel4/

which will be part of RHEL4. The reason you're seeing this bug is that
earlier versions of hal made certain (wrong) assumptions about the
sysfs-layout that are broken in the kernel you are using. Please see
if the new RPM's work.

Thanks,
David 

Comment 2 Stuart Hayes 2004-12-15 16:23:32 UTC
The 0.4.2 hal appears to work.  I tried it with a USB floppy, a USB 
CD-ROM, and a USB key (SanDisk Cruzer Mini).

When will this version of hal be included in RHEL4?

Thanks
Stuart

Comment 3 Amit Bhutani 2004-12-23 00:26:05 UTC
Confirmed hal 0.4.2-1.EL4 in pre-rc2. Closing.


Note You need to log in before you can comment on or make changes to this bug.