Bug 142925 - anaconda fails to write grub mbr as last phase of rhel as4 beta2 EM64T install
anaconda fails to write grub mbr as last phase of rhel as4 beta2 EM64T install
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-14 19:30 EST by bernie runnebaum
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 12:53:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bernie runnebaum 2004-12-14 19:30:58 EST
Description of problem:

installed rhel as4 beta2 em64t on a new hp dl360g4.
installs fine. (last message of install is that it is writing mbr...)
reboot.
os fails to load.
(message on screen stating system is trying to boot from cdrom, hd,
floppy... system hangs, does nothing.)

resolution:
boot from install disk, choose linux rescue option...
chroot /mnt/sysinstall (as directed)

now do this:

/sbin/grub --batch --device-map=/boot/grub/device.map 
    --config-file=/boot/grub/grub.conf --no-floppy
grub> root (hd0,0)
grub> setup (hd0)
grub> quit

reboot.

system boots normally now.


Version-Release number of selected component (if applicable):

rhel as4 beta2 em64t

How reproducible:

always. every single install ever tried on this hardware, multiple
boxes tried.

Steps to Reproduce:
1. install the os as directed.
2. reboot.
3. will not boot to the newly installed os until new mbr is written to
the drive using the process used above.
  
Actual results:

system will not boot ever after a straight out of the box fresh install.

Expected results:

os will boot after install.

Additional info:

upon request.
Comment 1 Jeremy Katz 2004-12-14 21:58:29 EST
Does this have some sort of cciss controller?
Comment 2 bernie runnebaum 2004-12-15 12:07:51 EST
it contains a new hp "smart array 6i" raid 0+1 array controller 
onboard. older hp dl360g3 were built with a "smart array 5i" raid 
controller on the motherboard.

http://h18004.www1.hp.com/products/servers/proliantdl360/index.html

we are using the scsi hd based machines.

the install program sees the drives, partitions and formats them, and 
installs the os on them. appears to just fail to write the mbr.

a japanese hp site which has controller info: 
http://translate.google.com/translate?
hl=en&sl=ja&u=http://www1.jpn.hp.com/products/software/oe/linux/mainst
ream/whatsnew/index_04.html&prev=/search%3Fq%3D6i%2Bdl360g4%2Bredhat%
26hl%3Den%26lr%3D%26client%3Dfirefox-a%26rls%3Dorg.mozilla:en-
US:official
Comment 3 Jeremy Katz 2004-12-15 12:53:48 EST
That's a cciss based controller.  I've fixed grub to properly write
the MBR to these since beta2.

Note You need to log in before you can comment on or make changes to this bug.