Bug 142927 - Evolution Connector fails to work with OWA & SSL & Forms-based-authentication page
Evolution Connector fails to work with OWA & SSL & Forms-based-authentication...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-14 19:48 EST by Ben Russo
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-19 14:04:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Russo 2004-12-14 19:48:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Exchange OWA servers with SSL and "Forms" based authentication page
cannot be logged into using evolution-connector prior to the current
2.0.3 release from the Gnome foundation.  It is a known bug that is
mentioned in the release notes for 2.0.3

I have had the fortune of testing this 2.0.3 release from a Debian
system and it worked. The same behavior with 2.0.2 was seen on the
Debian box.  

Would appreciate it greatly if the v2.0.3 (latest STABLE release from
gnome foundation) could be packaged up.

Version-Release number of selected component (if applicable):
evolution-connector-2.0.2-1

How reproducible:
Always

Steps to Reproduce:
1.  Have a Microsoft Exchange/OWA server with SSL and FORMS based
authentication page configured.
2.   Have evolution & evolution-connector version < 2.0.3
3.  When trying to log in the password dialogue hangs for about 2
minutes, then a message about failed login and asks for password again.
    

Expected Results:  After entering correct password with correct
authentication information, the personal folders list should be
displayed and the mail app should work intuitively.

Additional info:

Version 2.0.3 of evolution-connector is the latest STABLE version from
gnome.org it was released on Dec-08-2004, there were other bugs marked
as fixed as well, this might fix many other peoples problems?
Comment 1 Dave Malcolm 2004-12-15 22:09:40 EST
evolution-connector-2.0.3 should turn up in Rawhide in the next 12
hours or so; please can you test this and see if this fixes the problem.

Thanks
Comment 2 Osmo Laitinen 2004-12-16 08:35:22 EST
Tried these new evolution*-2.0.3 packages to fix my other bug (similar
to 139943), but other problem occured: I am not able to use my account
any more because the "authentication type" has been changed and cannot
be changed back to original.

"Authentication type" can be found from menu:
tools -> "settings" -> select your account and "edit" -> "receiving
mail". Evolution forces "Secure password" as authentication type and
if it changed to "plaintext password" the change won't happen after
pressing "ok". Also tried to restart evolution.

Packages are:
evolution-2.0.3-1.i386.rpm
evolution-connector-2.0.3-1.i386.rpm
evolution-data-server-1.0.3-2.i386.rpm
(and to satisfy depencies: libgal2-2.2.4-1.i386.rpm).. :-(
Comment 3 Ben Russo 2004-12-16 10:52:56 EST
The 2.0.3 packages fixed my problem with the OWA-2003-SSL+Forms based
authentication page.  I can see may mail, calendars, tasks, all work
well.  It also seems much faster!  :-)
Comment 4 Dave Malcolm 2005-10-19 14:04:22 EDT
I'm closing this bug as fixed in 2.0.3, since the original problem appears to
have been fixed.

If you are still experiencing problems with changing the authentication type,
please open this as a separate bug.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.