This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 142928 - ACPI suspend to RAM consumes too much power
ACPI suspend to RAM consumes too much power
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-14 20:08 EST by Matthew Saltzman
Modified: 2015-01-04 17:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:52:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2004-12-14 20:08:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When I suspend to RAM on my ThinkPad T41, the suspended machine
remains warm to the touch.  The battery is drained after 4-5 hours in
suspended state.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot with ACPI for power management.
2. Suspend to RAM.
3. Wait a while.
    

Actual Results:  Machine stays warm to touch.  Battery drains after
4-5 hours.

Expected Results:  Machine cools to room temp.  Battery lasts in this
mode for several days.

Additional info:

In /etc/acpi/events, I have a file sleep.conf containing:

event=button/sleep
action=/etc/acpi/actions/sleep.sh

And in /etc/acpi/actions/sleep.sh, I have:

#!/bin/sh
echo -n mem > /sys/power/state

APM suspend to RAM works just fine.

This bug is being tracked upstream at

http://bugzilla.kernel.org/show_bug.cgi?id=3022, 

but I thought it would be worth tracking here as well.  I'm sure a
number of ThinkPad users are affected and would like to see the fix. 
It's all that's keeping me from moving from APM to ACPI.
Comment 1 Matthew Saltzman 2005-02-19 20:50:52 EST
At http://bugzilla.kernel.org/show_bug.cgi?id=3022, they have
identified the main issue as failure of the radeonfb driver to suspend
the video chip.  There are now patches posted there that solve the
problem for a number of models of Thinkpad.
Comment 2 Thomas M Steenholdt 2005-05-26 02:20:53 EDT
The radeon D2, backlight patch is included in the latest development kernels
(the one i checked was kernel-2.6.11-1.1353_FC4) please test at let us know how
it works.

Please note, that for this to actually work, you'll need to have
"video=radeonfb" on your kernel command line. 

Then rebuild your initrd with (remember backup if you'll be needing it) :
   mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r) --with=radeonfb

Also, if your machine is not explicitly enabled in the kernel code for this...
you need to invoke the force_sleep functionality of the module BEFORE doing the
mkinitrd.

in /etc/modprobe.conf put a line like this :
   options radeonfb radeon_force_sleep=1

Hope this helps and works!
Comment 3 Matthew Saltzman 2005-05-26 07:55:39 EDT
Can this package be built easily for FC3?  I'd like to try it out, but I can't
afford to run test releases on this machine.  I once tried rebuilding an FCn
kernel on FCn-1, but was utterly defeated by the dependencies.

Thanks.
Comment 4 Matthew Saltzman 2005-06-29 09:33:40 EDT
Finally got to test this with kernel-2.6.11-1.1369_FC4 (FC4 release kernel). 
AFAICT, it works very well.  From my battery usage log:

Wed Jun 29 07:54:37 EDT 2005
before: 34660 mWh
after: 34060 mWh
diff: -600 mWh
seconds: 3555 sec
result: 607 mW
Congratulations, your model seems NOT to be affected.

600mW is probably still higher than it should be, but with the graphics chip
powered on the consuption is 4-5 times that.

Now if I could just have the penguin on the boot screen, my life would be
complete 8^).
Comment 5 Dave Jones 2005-07-15 13:51:37 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Matthew Saltzman 2005-07-15 16:34:33 EDT
Already updated to FC4 and so far the instructions from Comment #2 have worked
fine on all kernels through kernel-2.6.12-1.1398_FC4.  It would be nice if the
setup happened automatically, though.

All the Fedora Thinkpad users I know are now on FC4, but we have some RHEL4
Thinkpad users.  Will this patch be incorporated there?
Comment 7 Dave Jones 2005-07-15 18:52:26 EDT
for RHEL4, you'll need to file a seperate request.
Comment 8 Thomas M Steenholdt 2005-07-18 04:27:54 EDT
Please reopen?

I'm a fedora thinkpad user still on FC3 and the new kernel, with regards to the
power-saving, seems to work for me now.

However, on resume, i get this little problem
---
Back to C!
Debug: sleeping function called from invalid context at mm/slab.c:2126
in_atomic():0, irqs_disabled():1
 [<c011d3a4>] __might_sleep+0x9c/0xaa
 [<c0159762>] kmem_cache_alloc+0x3c/0x4c
 [<c023dc0c>] acpi_pci_link_set+0x4a/0x1a2
 [<c023e085>] irqrouter_resume+0x1c/0x24
 [<c027cb02>] sysdev_resume+0x5c/0xac
 [<c0280adb>] device_power_up+0x5/0xa
 [<c014878b>] suspend_enter+0x2d/0x46
 [<c0148727>] suspend_prepare+0x55/0x8c
 [<c0148814>] enter_state+0x39/0x55
 [<c023b087>] acpi_suspend+0x28/0x35
 [<c023b156>] acpi_system_write_sleep+0x5a/0x6b
 [<c0177075>] vfs_write+0xaf/0x10a
 [<c017717b>] sys_write+0x41/0x6a
 [<c010392d>] syscall_call+0x7/0xb
---
This is on a IBM ThinkPad T30 (2366-JBG)

If I can provide you with more info, let me know!

If you'd like me to submit a seperate bug, let me know about that too.

Thanks
Comment 9 Dave Jones 2005-07-29 20:45:08 EDT
Please file this as a seperate bug, thanks.

Note You need to log in before you can comment on or make changes to this bug.